Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow my colors in Terminal.app are completely borked. If I load up Vim with syntax on, there are no colors, but line numbers are underlined (and so are some other parts). It looks really really ugly. I can confirm that it's Terminal.app and not vim, because if I load up xterm it looks fine.

I have tried to restore defaults in preferences but it doesn't fix the problem.

share|improve this question
    
Maybe you could try trashing com.apple.Terminal.plist from ~/Library/Preferences. –  slhck Jan 14 '12 at 16:11
    
Thanks for the tip, didn't work unfortunately. –  Matthew Jan 14 '12 at 16:15
    
Make sure your $TERM environmental variable is correct. –  Heptite Jan 14 '12 at 16:53
    
Thanks @Heptite. When I type $TERM it says: bash: xterm-256color: command not found –  Matthew Jan 14 '12 at 17:46
    
Thank you so much @Heptite, changing the terminal to xterm-color in Preferences fixed my problem. –  Matthew Jan 14 '12 at 17:48
add comment

1 Answer 1

Make sure your $TERM environmental variable is correct. You can check it by doing:

echo $TERM
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.