Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use screen in iterm2 with this screenrc.

I try use the scroll with two fingers in the touchpad, but it doesn't work. I get this:

ss

Any suggestions?

share|improve this question

1 Answer 1

Screen has an internal scroll back buffer. Here's an introduction on how to use it.

You can also disable it by specifying that your Terminal is not capable of providing the mechanism screen uses to do its own buffer. Add something like the following to ~/.screenrc, creating it if it doesn't exist:

termcapinfo xterm-color|xterm|xterms|xs|rxvt ti@:te@

You already have it in your .screenrc, actually, but it appears you configured iTerm to report a different TERM than the xterm assumed in that file. You can change it in iTerm » Preferences » Profiles » (select a profile) » Terminal » Report Terminal Type.

share|improve this answer
    
with this line I get the same. And xterm is my TERM –  juanpablo Jan 14 '12 at 18:43
    
@juanpablo Does it work properly when you remove the hardstatus lines from your .screenrc? Does it work with an otherwise empty .screenrc? –  Daniel Beck Jan 14 '12 at 19:03
    
if I remove the hardstatus or I try with a empty screenrc, I have the same output. –  juanpablo Jan 14 '12 at 19:40
    
@juanpablo Odd. Or I misunderstood your question. Could you please explain (by editing the question) what it is you want to achieve, and what happens instead? I'm not sure I understand what's wrong with the screenshot. –  Daniel Beck Jan 14 '12 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.