Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I inadvertently yanked the power plug on my USB hub. My Logitech headset/mic was plugged into this hub, a fact which may or may not be relevant. Before I yanked the power cord, the headset was working.

Now it isn't. I've rebooted. I have plugged the headset into a bunch of different USB ports, not just on the hub bot on my case itself (ports I have verified as being fully functional). Windows 7 (x64) doesn't seem to recognize that it has been plugged in.

Is it possible my headset died of shock? I don't see any issues in the device manager. I guess I could reinstall my audio driver (sound is on-board), but I'm not clear if that could be a potential solution (to be clear, sound is otherwise working as normal on the machine).

share|improve this question
    
Help yourself by accepting more answers thus improving your accept rate. –  Celeritas Sep 25 '12 at 4:14
    
This question has one answer and it didn't solve the problem (I wound up getting a new headset; it seemed the old one had simply expired). So, should I accept the answer anyway to make you feel better about my acceptance rate? –  peacedog Sep 25 '12 at 12:18
    
I have asked 3 really obscure questions on this site; unfortunately they haven't been answered but they were shot-in-the-dark stuff. If I could mark accepted answers I would. Alas, it's not meant to be. –  peacedog Sep 25 '12 at 13:12
1  
I've had a similar experience with a Logitech USB soundcard (that had headphone and mic outputs) - computer had a very hard lockup, rebooted, now won't ever recognize the device. Other computers do recognize it, have you tried a different PC? –  studiohack Jan 29 '13 at 0:45
    
Did you only try connecting the headset through the hub? What happens if you connected it directly? –  Kruug Feb 12 '13 at 16:09

3 Answers 3

In my experience, I have seen this happen with other USB devices. Some of those cases were solved by de-energizing the system (even when you reboot equipment still has power). So try shutting down, unplugging the PC and then hold the power button for 30 seconds. Plug it back in and power up. Let it boot completely and then plug your headset in.

share|improve this answer

If you're having an issue with USB items going to sleep after an extended period of time, go into your Device Manager, expand the USB controller listing (should be the last one in your list) and turn off the Power Management settings. Should be worded something like "Allow the computer to turn off device to save power", give or take a word or two that I'm probably forgetting.

share|improve this answer
    
I don't think the OP's problem is that the USB item went to sleep. –  BenjiWiebe Feb 12 '13 at 16:48
up vote 0 down vote accepted

The headset wouldn't work on any of my USB ports, so I just replaced it. Had I access to another computer, I would have tried it there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.