Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to find something similar to iptables in Linux for Windows. I've tried using Windows firewall as well as editing the host file to block specific IPs, but had no success. I've also tried using WIPFW, but it wouldn't even install.. I was able to to use NetLimiter 3 to limit my connection speed to the specific IPs but whenever I setup a filter to block the IPs, those IPs can still connect.

I don't want a hardware firewall or router nor do I want a heavy duty firewall program. Ideally it would be a service that simply lets me add IP addresses and ranges and allows me to block / allow, incoming and/or outgoing connections. A GUI isn't even needed.

Suggestions?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You can use Netsh AdvFirewall in Windows 7 to issue advanced firewall commands. It's the closest thing you're going to get to iptables that isn't horrific like zone alarm.

Netsh Advanced Firewall

share|improve this answer
    
I've tried that too. It is essentially just a front to Windows Firewall, and for whatever reason, blocking the IPs there does not do anything. –  Slayer537 Jan 15 '12 at 2:02
    
I'm not sure what your end goal is here (why or what you're trying to block), but it's beginning to sound like you've got something hooked to your network driver. Like a virus. I mean, you can't even install WIPFW and advanced firewall commands do nothing. It's starting to smell a bit. Might want to do a scan and check things out. –  skub Jan 15 '12 at 2:28
    
The error I get with WIPFW is a problem other people have been getting too, it has to do with the drivers not being signed. I have a theory that there are conflicting rules in Windows Firewall which is allowing those IPs through. Definitely no viruses here. I keep my system clean. –  Slayer537 Jan 15 '12 at 3:19

NetLimiter 3 Pro will do this just fine, it was just configured poorly. Here is the correct setup:

  1. Create a Filter
  2. Under "Ip Ranges" put in the desired IPs, leave "Local" unchecked, and make sure "Match All" is checked
  3. Leave everything else default, click "Save"
  4. Go to the filter in the Node View and add and enable a rule

I think my problem was that I put in too many parameters in the filter and ended up causing it not to function properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.