Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new asus windows 7 laptop. Using the "AI Recovery" tool, I deleted the 8 gig windows recovery partition.

Now the Disk Management utility is showing my disk to be 111.79 GB rather than the 119.24 it was before. I seem to have lost the space that the recovery partition was taking up, rather than having it returned to use.

I'd like my 8 GB back, it's only a 128 GB disk.

--Edit-- Maybe it's not a 128 GB disk, maybe it's a 120 GB disk. I was comparing it against an identical laptop, except the HDDs are different. One is an ADATA XM11 128GB (114472MB) and the other is a SanDisk SSD U100 (122103MB). 8GB difference. Perhaps I didn't have as much space as I thought. Anyone with an XM11 want to tell me how many MB it's got in it. ADATA aren't telling.

DiskPart says Partition ### Type Size Offset


Partition 1 Primary 111 GB 1024 KB

share|improve this question
    
If you are unsure about your notebook specs, then just check the specpaper, it should tell you how much space your NB has. –  bamboon Jan 15 '12 at 15:03
    
Crank up diskpart. Run the list disk and list partition commands. Put the results in your question. –  JdeBP Jan 16 '12 at 13:07

2 Answers 2

Go to control panel -> administrative tools -> computer management -> storage -> disk management:

You should see all your partitions there, including the "lost" unallocated space.
Click on your systemdrive (probably C:) and there on extend volume. You will see a wizard which will guide you thru the process to add your lost space to your current partition(the C: partition).

share|improve this answer
    
Nope. First thing I tried. Can't extend. I shrank and then extended. Still the same size. –  Spike Jan 15 '12 at 14:51
1  
@Spike why did you shrink it in the first place? Make a screen please. –  bamboon Jan 15 '12 at 14:56
    
I deleted the recovery partition by accident. That tool deleted it when I clicked a checkbox. (Who writes a GUI like that?) I shrank it because I thought it might make the OS rescan the disk. Now I think it maybe it isn't lost, that the 128GB disk is only 120GB. –  Spike Jan 15 '12 at 15:04
    
@Spike if you deleted the partition, then there should be some unallocated space, or like you said you are mixing the numbers a bit. Post a pic or your NB specs, that should make it clear. –  bamboon Jan 15 '12 at 15:09
    
I've been looking for the specs on the HDD. The ADATA XM11 is not a consumer available product. They don't list the specs on the website. –  Spike Jan 15 '12 at 15:27

You can recover deleted partitions and much more by using TestDisk. You can find the procedure on how to do this here:

http://blog.eddsn.com/2011/02/how-to-recover-lost-or-deleted-partitions/

share|improve this answer
    
Please disclose your affiliation with TestDisk development group or the weblog you linked to in your answer, if there is one. –  Daniel Beck Jan 20 '12 at 15:57
    
The blog is mine. No affiliation with TestDisk. I saw that there were multiple questions on the problem with deleted partitions/data that I solved myself some time earlier which is described in the post on my blog. –  Edin Jan 20 '12 at 18:37
    
There are a few things here that are usually frowned upon. One is promotion without disclosure. Unless you overdo it, it's not a problem as long as you disclose it. Please start mentioning that it's your blog. The other is "link only answers", i.e. answers that become useless once a link goes dead. It'd be helpful if you could add a short summary to your answer, or quoted relevant blog post parts. –  Daniel Beck Jan 20 '12 at 18:41
    
Ok, I'll take care of that next time. :) –  Edin Jan 21 '12 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.