Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several large Excel (2003) workbooks, which are linked.

I open A.xls in Excel 2010, then open B.xls from Edit->Links. This works fine, and I can use B.xls.

If I then close B.xls, and try to open it again (either from File->Open, or Edit->Links), Excel claims the file is corrupted and wants to repair it. Opening the same file from a different Excel instance, or different computer, works just fine, but in that Excel instance, I can never open B.xls again. Closing everything lets both files be opened just fine, unless I close B.xls again and try to reopen it.

I've tried searching for answers, but I haven't been able to hit the exact combination of keywords that give me an answer, so I don't know if this problem is wide spread or not. I can reproduce it 100% using the same two excel files, but it doesn't happen with all files.

share|improve this question
    
This may be a problem with Dynamic Data Exchange (DDE) in those specific files. I can't help any further because I've been away from Excel too long. –  user3463 Jan 16 '12 at 4:31
    
To expand on it, it happens with several sets of files, but it's 100% reproducible within that set. –  lejordet Jan 16 '12 at 7:07
    
When you go to file - options - advanced - general is Ignore other applications that use Dynamic Data Exchange (DDE) checked or unchecked? –  Raystafarian Feb 8 '12 at 20:53
    
If you repair the file what does it say was repaired? I had a slightly similar problem where Excel 2010 was corrupting files on open. In my case it turned out to be a custom document property that was linked to a named range where the named range was referring to a value instead of a cell in the workbook. –  mischab1 Feb 9 '12 at 1:42
    
"Repairing" a file only gives you an unstyled file with the values from the file. It works perfectly without repairing if opened in a separate instance of Excel (or opened by someone else). DDE is unchecked. –  lejordet Feb 9 '12 at 9:08
show 1 more comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.