Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ubuntu 101.10 Firefox 9.0.1

Edit > Preferences > Content > Language > Choose ( reveals the en-us dictionary )

Hi. I'm running the above browser and OS combination. When I go to the above menu path I see the dictionary for American English. However, the spellchecker will mark American spellings as being wrong and British spellings as being correct ( ie favor vs favour, realization vs realisation ).

I went to the above path, uninstalled the dictionary, reinstalled it and restarted Firefox. The listed dictionary is en-us, but I am still getting a British spellcheck. Any ideas on what I can do to fix this problem?

Thanks.

share|improve this question
    
Is your Ubuntu user account localized to English-GB? – iglvzx Jan 16 '12 at 1:01
    
iglvzx....how would I determine ( and change ) that? – user787832 Jan 16 '12 at 14:06
1  
I went into System > Admin > Language Support. Ubuntu is set for American English. – user787832 Jan 18 '12 at 1:22
up vote 3 down vote accepted

In Firefox, in any multi-line edit window, right click and go Languages > English / United States. That solved the problem for me. For some reason I don't understand (upgrades?) it gets reset occasionally.

You might also want to ensure you don't have any undesired languages installed: Tools > Add-ons > Languages. Disable or remove any you don't want.

share|improve this answer
    
Thanks Alan, that worked. I didn't find a "Languages" node after Tools > Add Ons. I only found US English in Edit > Preferences > Content. Any idea how I could remove the files for those other versions of English? Thanks again! – user787832 Mar 17 '12 at 16:08
    
Find picture included instructions of above, on the sub site for Unix/Linux questions - askubuntu.com/questions/50049/… – user66001 Mar 17 '14 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .