Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using debian wheezy and iceweasel, I somehow managed to have it no longer redering text in pre tags. It still shows the background but no text. This is no color problem, I cannot select anything. I can see the code using "show selection source".

I have already tried reinstalling the iceweasel package, and running in safe mode, but to no avail.

As a sidenote, it might be more than just pre, the textarea for asking and answering questions on stackechange have it also. The cursor just stays in the left of the textarea and I only see what I am typing thanks to the instant preview.

Recent changes to my system is that i tried to install monospace fonts like consolas and inconsolata, which failed (they show as boxes), and that I played around with the system default fonts in gnome tweak tool... However changing settings doesn't resolve the problem on first sight...

Tor browser bundle, which has a completely different profile as well as executables also has it.

I tested by making some monospace text with css and it still shows monospace fine... Another textarea on a site I am building works fine, I don't know what is special about the ones on stack exchange.

I know I am very talented in making software break, but it is really incredible how it can break in such ridiculous ways though...

Any clues more than welcome, I am flabbergasted.

share|improve this question

1 Answer 1

I suppose it's a fonts issue. Open settings -> content -> fonts, hit the advanced button and check the font that's set for fixed width text.

share|improve this answer
    
Hi, thanks it was on monospace, changed to DejaVu sans anmono and it makes no difference. Anyways, these settings are not shared between my installed firefox and tor browser bundle. btw opera is fine –  ufotds Jan 16 '12 at 21:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.