Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is 2 computers here, 1 is running Debian 6 and one - Windows XP. They are both connected via Wifi but cannot ping each other.

But, when one is connected via a wired connection, I can ping the wired one from the wireless one. And once I ping it (but not before!), pinging from the wired to the wireless also works.

So Why are the computers not seeing each other? Is there a way to correct this and make the network work when both are connected wirelessly?

Update: more details...

Router IP is 192.168.2.1, subnet mask 255.255.255.0. DHCP configuration for clients.

Windows XP IP: 192.168.2.100, subnet 255.255.255.0 Debian IP: 192.168.2.103, subnet 255.255.255.0

Windows XP routing table:

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.2.1   192.168.2.100       25
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      169.254.0.0      255.255.0.0    192.168.2.100   192.168.2.100       20
      192.168.2.0    255.255.255.0    192.168.2.100   192.168.2.100       25
    192.168.2.100  255.255.255.255        127.0.0.1       127.0.0.1       25
    192.168.2.255  255.255.255.255    192.168.2.100   192.168.2.100       25
        224.0.0.0        240.0.0.0    192.168.2.100   192.168.2.100       25
  255.255.255.255  255.255.255.255    192.168.2.100   192.168.2.100       1
Default Gateway:       192.168.2.1
===========================================================================
Persistent Routes:
  None

Debian routing table:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0
default         192.168.2.1     0.0.0.0         UG    0      0        0 wlan0
share|improve this question
    
When both are on the wireless network, do they have the same subnet mask? –  user3463 Jan 16 '12 at 4:38
    
@Randolph West Yes, they do. –  Abbafei Jan 16 '12 at 4:50
    
can you post interface ip and routes from both machines and router ip/mask as well? –  daya Jan 16 '12 at 4:59
    
I take it you've tried disabling any firewalls on the Windows side? –  Amos M. Carpenter Jan 16 '12 at 5:00
1  
@aaamos IP address. –  Abbafei Jan 16 '12 at 5:23
show 2 more comments

1 Answer

Sounds like multicast is broken on your wireless network, so ARP broadcasts aren't getting through (broadcasts are treated like a subset of multicasts on wireless).

Broken multicast is, unfortunately, a fairly common problem on wireless networks. There are several common causes:

  1. Bugs in multicast cipher handling in the AP or client(s). You can test if this is the case by temporarily disabling security on your network. If that helps, try pure WPA2 AES-CCMP mode next (not mixed WPA/WPA2 more or any kind of mixed security mode for that matter). If pure WPA2 mode doesn't work, try pure WEP-104 (128) mode.

  2. Bugs in power save mode handling the AP or client(s). Try disabling power save mode in the driver properties of all your clients. This may be called something like "Max Performance Mode" instead of being called power save mode.

  3. Multicast rate set too high. Try temporarily lowering your multicast rate to the lowest setting and see if that improves things.

  4. Other multicast-related bugs in the AP or client(s). Make sure you have the most recent firmware on your AP, and the most recent 802.11 drivers on your clients. Also consider investing in higher-quality 802.11 equipment. Apple products make a lot of use of multicast because of Bonjour, so Apple's AirPort line of 802.11 APs always seem to handle multicast well.

Note that your problem could be a combination of factors, so be sure to try all of those things at the same time if the one-at-a-time approach fails.

Another useful troubleshooting step when ARP seems unreliably on your network is to manually enter static ARP mappings on each machine, for each of the other machines. On Unix-like OSes, this is usually done something like this:

sudo arp -s <IPaddr> <MACaddr>

It would also be good for the sake of future readers of your Question if you name the make, model, hardware revision, and firmware or driver version of your AP, and your two client cards. If you can find the make and model of the 802.11 chipsets involved as well, that would be good to know too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.