Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up a PC for a 5-year-old. I want to allow access to the Internet to a handful of sites only.

  • Tried IE Content Advisor, but it doesn't support blocking all (or I missed something)
  • I tried the proxy method, where you set a fake proxy and make the required sites to bypass proxy. I don't like this method as it blocks whatever other software that uses IE settings.
  • No such option in Windows 7 parental control
  • BullGuard's parental control, has options to trust a site, but doesn't block all except few.

Any other suggestions?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Microsoft Family Safety (part of the Live Essentials suite) has this feature. You can BLOCK ALL except for the list of sites that you maintain.

To enable this feature:

  • select the user in question
  • go to Web Filtering
  • turn on web filtering
  • move the slider all the way up to "Allow List Only"

Separately you can maintain the list of sites that you allow in "Web Filtering Lists".

share|improve this answer
add comment

I found the answer to this one for IE only here:
http://www.iishacks.com/2009/03/12/using-the-ie-content-advisor-to-block-all-internet-access/

  1. Copy the following text into Notepad and save it as “noaccess.rat” in the Windows\system32 directory (or another directory of your choice). Be sure that the file extension is .rat and not .txt. You can download a zip file containing noaccess.rat here.

    ((PICS-version 1.0)
     (rating-system “http://www.microsoft.com”)
     (rating-service “http://www.microsoft.com”)
     (name “Noaccess”)
     (description “This file will block all sites.”)
    
     (category
      (transmit-as “m”)
      (name “Yes”)
      (label
       (name “Level 0: No Setting”)
       (description “No Setting”)
       (value 0))
      (label
       (name “Level 1: No Setting”)
       (description “No Setting”)
       (value 1))))
    
  2. In the “Control Panel” double-click on “Internet Options” and click on the “Content” tab. If in Internet Explorer, click on “Tools” and “Internet Options” and click on the “Content” tab.

  3. Click “Enable.”

  4. Inside the “General” tab click on “Rating System.”

  5. Remove all entries and click “Add.” Add “noaccess.rat” from the Windows\system32 directory.

    enter image description here

  6. Click on the “Approved Sites” tab and add all the websites you wish to allow access to.

    enter image description here

Also, remember to tick off the box on Content Advisor -> General -> "Users can see websites that have no rating." Obviously other browsers will ignore these settings, but in my case I did use Parental Controls to avoid this.

share|improve this answer
    
I have problems with this. IE behaves very strange with redirects. Do you know of any known problems? As soon as I turn it off everything goes back to normal. –  Gunslinger Feb 26 at 10:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.