Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

see i found one config file in which this are macro defined

#
# Input Device Drivers
#
CONFIG_INPUT_KEYBOARD=y
# CONFIG_KEYBOARD_ADP5588 is not set
CONFIG_KEYBOARD_ATKBD=y
# CONFIG_KEYBOARD_QT2160 is not set
# CONFIG_KEYBOARD_LKKBD is not set
# CONFIG_KEYBOARD_GPIO is not set
# CONFIG_KEYBOARD_TCA6416 is not set
# CONFIG_KEYBOARD_MATRIX is not set
# CONFIG_KEYBOARD_LM8323 is not set
# CONFIG_KEYBOARD_MAX7359 is not set
# CONFIG_KEYBOARD_NEWTON is not set
# CONFIG_KEYBOARD_OPENCORES is not set
# CONFIG_KEYBOARD_STOWAWAY is not set
# CONFIG_KEYBOARD_SUNKBD is not set
CONFIG_KEYBOARD_OMAP4=y

But i dont understand which macro should i enable for connecting USB keyboard with pandabord ?Is there any documation for this config files macro?

share|improve this question

migrated from stackoverflow.com Jan 16 '12 at 8:39

This question came from our site for professional and enthusiast programmers.

3  
These are not macros and your question is not programming-related. –  tripleee Jan 16 '12 at 8:02
    
Maybe you want a configuration for USB HID en.wikipedia.org/wiki/USB_human_interface_device_class like CONFIG_USB_HID and others but stackoverflow is the wrong place to ask. –  Basile Starynkevitch Jan 16 '12 at 8:14
1  
And you can get some documentation with e.g. make menuconfig –  Basile Starynkevitch Jan 16 '12 at 8:18
add comment

2 Answers 2

up vote 3 down vote accepted

These are not macros. This is the config file generated before compiling a kernel generated by "make menuconfig" or "make xconfig" etc.

These indicate what drivers are to be built when kernel is compiled.

'y' means support is built into the kernel

'm' means the driver is built as a kernel module

share|improve this answer
add comment

Check the Compatible driver code and with each driver there will be macro defined in Makefile. Select that macro as y or m based on your requirement. Also dont forget to select the depandent drivers for your keyboard which may be USB core and hid drivers. I will suggest better run make menuconfig for your architecture and select your keyboard driver. That will enable all depandent drivers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.