Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

when logged in as user 'www-data' on my debian server (squeeze) i want to use bash-completion. I follewed this guide, but i doesn't succeed: it is working for all regular users but not for www-data! what's wrong?

share|improve this question

migrated from stackoverflow.com Jan 16 '12 at 10:33

This question came from our site for professional and enthusiast programmers.

4  
When you log in as www-data often enough that bash completion is worth the hassle, you have a serious problem with the administration. –  thiton Jan 13 '12 at 10:48
    
Are you sure that www-data has correct shell? Check by echo $SHELL or echo $0 in console. –  4ndrew Jan 13 '12 at 10:53
    
@4andrew: that's the fault! 'sh' was the enabled shell ... thanks fpr your answer. –  user1116675 Jan 13 '12 at 13:23

1 Answer 1

As a normal user with bash completion do:

sudo -u www-data #rest of command here#

and you'll get the rest of the command allowing bash completion.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.