Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is a JRE 1.7 on my Windows XP machine. The java -version command says that I have 1.7.0_02.

By launching an .exe file, I want to install an internet banking software that uses Java, but it said that I have to install a JRE higher than 1.4.

I've also tried to run that program with JRE 1.6 (which is also installed on my machine), but the error is still the same.

share|improve this question
It sounds like this particular program's JRE version detection may be broken. – afrazier Jan 16 '12 at 20:11
Tell your bank that it's no use pretending that the economic crisis hasn't happened and that they need to join us in the future. – Mokubai Jan 16 '12 at 20:25
Hmm.., what do you mean? – maks Jan 16 '12 at 20:58
up vote 2 down vote accepted

There are right ways to detect program versions and there are wrong ways.

Especially with Java, there may be requirements that not only a "higher than" version be present, but sometimes even a very, very specific version and higher versions won't work any better than lower versions.

This program appears to be using either the wrong method of determining version, or it uses the right version and then uses the wrong words to communicate what it really wants.

The fix is to either install Java version 1.4 (not recommended, there have been a lot of critical security holes patched since then) or tell your bank that you need a new version of the software that doesn't have such gaping security issues.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .