Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have strange problem at my Windows 7 laptop. All TCP connections have some delay between TCP handshake and actually sending data. This makes all browsers (tried Aurora, Chrome, Opera and IE 9) hang for some time. Also this causes Skype to come online for very long time (up to 5 minutes).

I checked network traffic with Network Monitor. I have found out there is a random (4 to 30 seconds) delay between TCP handshake and sending data:

-------------- handshake begin ---------------------
3   1.1434242   CAVE TCP TCP:Flags=......S.
5   1.1630603 CAVE    TCP TCP:Flags=...A..S.
7   1.1635530   CAVE TCP TCP:Flags=...A....
-------------- handshake end --------------------------
215 14.1408929  CAVE HTTP    HTTP:Request

Also I've noticed when I started Fiddler (so any browser traffic went through it) this delay has disappeared. I have no explanation of this.

I have Symantec Client Security installed. However even when I stopped it completely (disabled all related services and rebooted) problem was same

share|improve this question
Are you using any kind of proxy? Also are you on your home network you administer or is this a network that someone else is the administrator (i.e. The network at work or free public wifi)? – Scott Chamberlain Jan 16 '12 at 22:38
Do other PC's in your home have the same problem? Do you use wifi or a cable? – Robert Jan 17 '12 at 15:01
I experience that in both home and work network. Problem occurs only at my PC. Any other PCs in both networks have no such problem. Problem occurs on both wifi and cable connections. – Ralfeus Jan 19 '12 at 14:54
up vote 0 down vote accepted

I have found out the reason of the problem. I use Open Text Socks client. When it's enabled problem occurs. When it's disabled everything works fine. I tried another socks proxy client (Proxifier) - it doesn't cause such problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .