Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Firefox with a proxy. Every time I restart the browser, I have to enter the proxy's username and password.

Is there any way to get Firefox to remember the username and password and send it automatically so I don't have to type it in manually?

NTLM won't help as the proxy is unrelated to my Windows set-up.

I see this question was already asked. The accepted answer was to use FoxyProxy. This didn't solve my problem, however, as I was still prompted for the username and password the first time in the browsing session that I needed to use the proxy.

Prompt

share|improve this question
    
Can you add a screenshot for the password prompt? The default proxy auth dialog for firefox includes a checkbox to remember the password, so perhaps it is a prompt from the proxy itself. – Paul Jan 16 '12 at 23:23
1  
@Paul: I told Firefox to remember the password, and it did - it just displays the prompt filled-in. I still have to hit 'enter', though. Is there a way to not even have to do that? (I ask for automation purposes, but consider me an impatient user if that helps =P). It is definitely a prompt from the proxy itself.. I'd just like Firefox to remember the details + send them without asking me. – Claudiu Jan 16 '12 at 23:31
    
Sure - my point is that the proxy auth prompt in ff will remember the details and normally not prompt once remembered. If it is a webform presented by the proxy, then the approach would be different. A screenshot would help identify which is occuring. – Paul Jan 16 '12 at 23:40
    
@Paul: updated the question. That's what I saw when I just turned on firefox and typed in an address. (Sometimes I get one with a checkbox to get password manager to remember the password, but it's already checked.) I didn't see what you meant by whether the proxy did it, but yea it's not a web-form. – Claudiu Jan 16 '12 at 23:52
    
Hmm. Yeah, that is a proxy auth dialog rather than a form. I think this might be the way the proxy is set up for auth, as I have a similar situation and I get that prompt once in a while, not every startup. Perhaps autohotkey is the answer. – Paul Jan 16 '12 at 23:57
  1. Browse to about:config in Firefox
  2. Click on "I'll be carefull, I promise!"
  3. Search signon.autologin.proxy and network.websocket.enabled in the Search Input Box then change their values as follow:

    signon.autologin.proxy=true
    network.websocket.enabled=false
    
  4. Restart Firefox, input user name and password for your proxy and click Remember.

share|improve this answer
    
Can you elaborate a little more on the steps to getting to these settings? Some users/visitors may not know about about:config or how to get to it. – druciferre Sep 27 '13 at 1:02
1  
The first setting makes sense, but the second one actually disables a technology which had a bug in this area that now seems to be fixed. Maybe correct the answer if the situation has indeed changed? – Robert Grant Aug 29 '14 at 6:12
1  
This did not work for me as I do not see any "remember my password" checkbox option. – newUserNameHere Jan 2 '15 at 11:05

Proxy password problem in Mozilla Firefox 3 - SOLVED by accident :)

  1. Start Firefox 3
  2. In Address bar write "about:config"
  3. In filter write network.auth.use-sspi
  4. Double click on "true" and it should become "false"
  5. If things does not become better write here to give other changes I made. So far nothing else worked until this change

Try it. It might solve your problem. Credits to Revell

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .