Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, I downloaded SQL Developer 3 with SDK and was able to use it just fine. After shutting down my PC last night and booting it up again this morning, every time I try to run it, I get this message:

"Enter the full pathname for java.exe"

I browse to C:\Program Files\Java\jre6\java.exe where the EXE is located and I get this message:

"Cannot find a J2SE SDK installed at path C:\Program Files\Java\jre6\java.exe"

What could be the issue here when it was working just fine yesterday? I will add that my PC did freeze last night during shutdown, so I ended up having to power it off, but I don't know if that's relevant.

I reinstalled Java and it still gives the same message. I also downloaded SQL Developer without the SDK and get the same message. I will also add that I am not actually installing SQL Developer, just running the executable from the folder. I don't think you actually install it anyway.

Anyone know what could be causing this? I am on Windows 7 32-bit.

share|improve this question
I appear to have fixed it my uninstalling Java and deleting the SQl Developer program folder. I then reinstalled Java and re-extracted SQL Developer and it works now. Before I put this as my answer, I'll see what everyone else has to say, if anything. – oscilatingcretin Jan 17 '12 at 15:10

12 Answers 12

up vote 6 down vote accepted

"jre6" in the folder name implies you have JRE installed there, and not the SDK. Point it to somewhere where you have java.exe of a JDK/SDK installation, instead of JRE, and from thereon it should work.

If you had to power off during shutdown, it might've not been able to save the SDK reference, thus asking it on the next startup.

share|improve this answer
After booting up my PC again today, I was greeted with the error message yet again! I searched my C drive for java.exe and found out that there was a copy deep in the folder that I extracted the ZIP file I downloaded. Specifically, it was in sqldeveloper-\sqldeveloper\jdk\jre\bin. I pointed it to that and worked! – oscilatingcretin Jan 18 '12 at 17:48

If your jdk file gets stuck on asking for the jdk file on repeat in windows 7, or you are having problems with the jdk file, try running SQLDeveloper as administrator rather than just the regular startup.

share|improve this answer
This was my problem. I also recommend that you only open as administrator the once, set the Java path, close and open as normal. You shouldn't need to run as admin more than once. – Dan Atkinson May 2 '13 at 9:46

I encountered the following message repeatedly when trying to start SQL Developer from my installation of Oracle Database 11g Enterprise: Enter the full pathname for java.exe.

No matter how many times I browsed to the correct path, I kept being presented with the exact same dialog box. This was in Windows 7.

The solution was to right-click on the SQL Developer icon and select "Run as administrator".
I then used this path: C:\app\shellperson\product\11.1.0\db_1\jdk\jre\bin\java.exe

share|improve this answer

Resolved. It didnt work for me but after spending lot of time , here is what what I did to fix it.

1) Open the file


and add the following line to set jdk path:

SetJavaHome C:\Program Files\Oracle\11g\product\11.1.0\client_1\jdk

If it don’t allow you to save the file, copy whole sqldeveloper folder to a different location where you have write access to modify this file.

2) Run sqldeveloper.exe (from the new place if you moved the folder out from oracle folders) as administrator and enter the jdk path that comes with your oracle installation:

C:\Program Files\Oracle\11g\product\11.1.0\client_1\jdk\bin

It should work then... hope it will help you save hours. - snehal

share|improve this answer
At least in version 4 of SQL Developer, there is also a product.conf in your roaming profile that also sets a line for SetJavaHome. If product.conf exists, you either need to rename it, or SetJavaHome there instead of sqldeveloper.conf:… – Sun Mar 31 '15 at 16:57

Try entering the full path to java.exe while using SQL Developer. For example:

share|improve this answer

If you are in 64 bit environment, you need to install the latest java 6 SE for 32 bit and use that (oracle calls these versions i586 eg, Jdk-6u45-windows-i586.exe).

share|improve this answer

I found the file(sqldeveloper.conf) in this path


and then I set the javahome like below, previously it was pointing to the jdk1.7

SetJavaHome C:\Program Files\Java\jdk1.6.0_06

share|improve this answer
The key point is that it is D:\app\admin\..., because the user is admin, so it will be changed according to the user. And where to look in your pc , the location can be found in the 'path' environment variable'. It is like that in my pc : D:\app\admin\product\11.2.0\dbhome_1 – Manoj Kumar Apr 19 '15 at 6:53
You can include you explanation in the answer itself. There is no need for mentioning it separately in the comment. Answers explained in details are always welcomed. :) – Ayan Apr 19 '15 at 12:23

Try setting the path below. It worked for me.

C:\Program Files\Java\jdk1.7.0_79

To cross check, you can check the path specified to locate JVM in the configuration file:

share|improve this answer

When SQL developer asks for Java path, mention the path as including java.exe also:

C:\Program Files\Java\jdk1.6.0_06\bin\java.exe

This worked for me.

share|improve this answer
Can you clarify your answer- do you mean editing the $PATH variable to include the location you mentioned? If so, how? – bertieb Aug 11 '15 at 10:05

Check your sqldeveloper.conf file. It contains:

SetJavaHome ../../jdk

This means when SQL Developer starts up it will look in the ../../jdk folder for java.exe.

Once you've installed a version of JDK, copy the folder to ../../jdk location relative to the sqldeveloper.conf file (which you can find in /bin folder).

/installed folder
    /jdk   <== create this and copy jdk stuff here


then you won't be prompted with the question.

share|improve this answer

the solution, in the sqldeveloper.exe icon, press right button clic and the compatibility part, select, run this program in compatibility for Windows XP(Service Pack 3). down select ejecute this program as Administrator, press Acept,

run again the program, select the java folder, press select, ready. this will function.

share|improve this answer
The OP states the platform is Windows 7. – suspectus Aug 27 '15 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .