Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With previous Outlook version or installation, whenever I got a meeting invite, it was automatically added to my calendar as 'tentative', without me needing to open the meeting request. Now I need to open the meeting request for this to happen, which I don't want.

Is there a way for me to have meeting invites automatically added to my calendar as tentative, and if, how?

EDIT: so what I'm really looking for is that they'd be added to my calendar view even though no action would be made or implied regarding them. This is what happens if I open a meeting request that has been sent to me - I want that to happen automatically.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I think I've fixed this now.

Answer in short

Check that meeting request processing is enabled.

  • Previous Outlooks: Tools -> Options -> Email Options -> Tracking Options -> Process requests and responses on arrival and Process receipts on arrival
  • Outlook 2010: File -> Options -> Mail -> Tracking -> Automatically process meeting requests and responses to meeting requests and polls

This did the trick for me.

Answer in more detail

Since Outlook 2000 but pre-Outlook 2007 there has been a process called Outlook Sniffer. Outlook Sniffer is responsible of following actions:

  • Meeting invites (adding tentative meetings to your calendar)
  • Meeting updates (updating details in your calendar)
  • Task updates
  • Message recall (when someone recalls a message you've received)
  • Responses to voting buttons (when you sent a mail with voting buttons, this adds the voting responses back to the original item)

The Outlook Sniffer runs as a MAPI idle process. This means the Sniffer will not process when Outlook downloading emails from the server, where as it processes if you are composing and email. So if the Outlook is busy due some MAPI activity, which can be due to a third party add-on, the Sniffer may not trigger and you will not get the necessary output as desired.

When a new meeting request arrives in your outlook inbox, sniffer marks it in the outlook calendar as tentative appointment, so you will get a reminder for that request even if you forget to accept/reject the meeting request. Sometimes the time taken for different meeting requests will differ; this is because the sniffer runs only when MAPI is idle.

There can be several reasons for the Sniffer to not process calendar requests.

  1. Sniffer only works with Inbox items. If you don't get the request in your Inbox, for example due to a rule, Sniffer will not act on it.
  2. Outlook might be configured in a way that Sniffer will not check incoming requests. This is handled by "Automatically process meeting requests" setting defined in email tracking settings.
  3. If user mailbox is configured in more than one machines, only one of them can be the Sniffer owner. /sniff startup parameter can be used to check this, and /cleansniff to clear out current Sniffer ownership state.
  4. Third-party add-on might mark an item as sniffed, and in that case Sniffer will not act on it. This can be checked using the tool MFCMAPI from item property PR_PROCESSED.
  5. As previously explained, if MAPI is not idle, Sniffer never runs. A third-party extension might cause it to be never idle. In this case, you can try disabling add-ons.
  6. Sniffer idle time might be set to too long. In this case, it can be so slow it is never noticed, or some other activation mechanism always processes items before Sniffer has a change to. This setting is defined in HKEY_Current_User/Software/Microsoft/Office/11.0/Outlook/Options/General, in the following keys:
    • AutoProcessIdleTime – how much MAPI idle time is required before the Sniffer will act. In milliseconds, DWORD value.
    • AutoProcessIdleTimeMax - this says to wait for how long for the next try if the MAPI was not idle on the previous attempt. In milliseconds, DWORD value.

On Outlook 2007, "all meeting message processing for a regular mailbox is done by an Exchange assistant called Calendar Assistant which add meetings to your calendar as tentative meetings automatically." What they propose as a fix is to

  1. Try to run Outlook /cleansniff
  2. If that fails, there are instructions to edit registry keys. Proceed with caution, I take no liability as I haven't tried this myself.

Information was learned from this thread and this article.

share|improve this answer
    
I know I'm necroing the heck out this, but "Sniffer only works with Inbox items. If you don't get the request in your Inbox, for example due to a rule, Sniffer will not act on it" isn't true in Outlook 2010. I have a gazillion different rules that run and drop stuff into folders, and even the meeting invites that get moved to Deleted Items still end up on my calendar =/ –  Ross Aiken Jun 17 '14 at 15:24
    
@RossAiken seems so, and one of my references actually says that Sniffer is actually used pre-2007, and since 2007 there has been a "calendar assistant" process. I'll need to update my answer. –  eis Jun 17 '14 at 21:28
1  
People like you are why I like this site. Two-year-old answers still get updated. Nice work. –  Ross Aiken Jun 18 '14 at 21:31
    
Thank you! .. :) –  eis Jun 19 '14 at 6:54

Try this - File, Options - Calendar - Scroll to the bottom and find Resource Scheduling, click the button - Click automatically accept meeting requests.

Now - how to make it accept tentatively. I can;t seem to find an answer to that

share|improve this answer
    
Accepting them automatically would be a different thing. I don't want to accept them, I just want them to be added to the calendar, so based on a quick view I can see what meetings have been proposed to me, even though I don't know if I can make it or not. –  eis Jan 17 '12 at 19:44
    
Outlook should always add new meeting requests to the calendar as tentative. If that isn't happening, there is a problem. Do you always have Outlook running? –  uSlackr Jan 17 '12 at 19:47
    
Always doing working hours. –  eis Jan 17 '12 at 19:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.