Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on a WinXP machine in a LAN.

Through the LAN my computer connects to a server that has some shared drives I need to access.

I usually connect to the internet through that server (which also functions as DHCP, and has a broadband network).

Today our internet service is down so I connected my computer to my iPhone's Personal Hotspot via USB. This makes my "Network Connections" in the control panel to show two different "LAN or High-Speed Internet" connections.

The problem is that, for my computer to be able to access the Internet I have to disable the Network Adapter that I use to connect to the LAN and the Server (and the shared drives). Otherwise, Windows just ignores the iPhone's adapter and tries to connect to the internet via the LAN (which of course fails).

Is there a way in which I can tell the computer to use the iPhone's Connection for internet, and simultaneously use the regular Network Card for all the local access stuff?

I was reading something about the "default gateway", but I am not sure whether I can modify this without disabling the "Obtain IP address automatically" setting on the Network Card.

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Multiple default gateways will be a problem in this scenario. Which one is used is based on an interface metric which is based on speed. However, since both will provide a similar metric (in this case) it will default to the first one via Automatic Metric. Overcome this by setting the metric yourself (for the time being).

For both interfaces:
1. Open the properties of your adapter (by reading your post it seems you are familiar with this).
2. Click Internet Protocol Version 4 (TCP/IP).
3. Click Properties.
4. Click Advanced.
5. Uncheck Automatic Metric.
6. Change the Metric of the one you want to be "master" to 1 and the other to 2.
7. In this case your iPhone would be 1 and the other would be 2.
8. When done change it back.

This should work based on local / remote lookups, I haven't tested it, but in theory it is correct.

share|improve this answer
    
It works! I had been juggling with the Metric but hadn't found a way to make it work. I did as you explain and it has been working. It is a little glitchy but I also expect some of the fault will be on my mobile provider (which is alwas glitchy and sometimes really slow). At one point I realised I had set both metrics on "2" and it was working nonetheless. Then I set "1" for iPhone and "2" for Network Card and hope it will be more stable now. Thanks man! –  Ozkar Jan 18 '12 at 19:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.