Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Notepad++ v5.9.6.2 (Unicode) on Windows 7 (64 bit) and I have installed the HEX-Editor v0.9.5 plugin.

The problem is that only administrators now seem to be able to run Notepad++. With guests and normal users the following happens after launching:

  • First absolutely nothing happens for about 20 seconds.
  • Then a dialog called "C:\Program Files (x86)\Notepad++\plugins\HexEditor.dll" appears. It reads:

    Fail loaded

    This plugin is not compatible with current version of Notepad++.

    Do you want to remove this plugin from plugings directory to prevent this message from the next launch time?

  • After I click "No" a shorter wait, followed by another dialog, called "Exception On WM_CREATE". It reads:

    Unknown exception

Again, for administrators everything works fine.

I checked if it had anything to do with security constraints on the plugin files (or other Notepad++ files), but this doesn't appear to be the case. If I make a user member of Power Users but not Administrators, then Notepad++ works fine for this user as well. I granted the Power Users group almost the same local user rights as the Administrators group. (Administrative Tools > Local Security Policy > Security Settings > Local Policies > User Rights Assignment)

What could be the problem and how should this be fixed?

share|improve this question
add comment

3 Answers

Try this

  1. login as admin
  2. right click on notepad++ then property,
  3. in compatibility tab, check "Run this program as administrator".
  4. Then click "Change setting for all user"
  5. Logout and login with guest account or normal user account
  6. run notepad++ again.

Problem is probably due to the fact that to access to .dll files require admin privilege.

share|improve this answer
    
Thanks. To be clear: my "power user" is not in the admin group. That was the whole point. I did grant the power users group almost the same rights as admins in the "Local Security Policy". –  Rinke Jan 17 '12 at 18:42
    
Letting all users run Notepad++ as administrators seems like a bad idea to me, but maybe I don't see it right. It seems to me that everyone would for example be able to browse the file system as an administrator through the "Open file" dialog. Not something I want. Is there an alternative you can think of? –  Rinke Jan 17 '12 at 18:48
add comment

in my opinion it's independent of administrative privileges. A missing Folder named plugins in C:\Users\%username%\AppData\Roaming\Notepad++ is the problem. After copying the data from the folder of an other user the error is gone.

share|improve this answer
add comment

I think the problem is in fact an attempt by the plugin to modify restricted files somewhere in Notepad++'s installation directory. I had the same problem with Notepad++ itself, which I solved by installing in the Public user profile directory. It seems that Notepad++ and its plugin authors are not very conversant with Windows security arrangements. Aside from moving the installation directory, you could liberalize the security permissions on the relevant Program Files subfolders.

Also, I think that raw disk access, which a hex editor would likely seek to acquire (I know all the hex editors I have used have done so) may require administrative privilege.

share|improve this answer
    
Nope. Already checked it as I explained in my question. As a second check I added full control for "Everyone" to the whole Notepad++ subtree. Makes no difference. –  Rinke Jan 17 '12 at 22:05
    
By the way, a hex editor does nothing special in terms of file access. If you can read a file, you can read all bytes. You can interpret these as encoded characters (as done by text editors) or you can simply show the raw bytes (as done by hex editors). –  Rinke Jan 18 '12 at 15:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.