Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I am using ee editor in FreeBSD 8.1 box. I cannot type numbers though. I open a file with:

ee file

I start writing letters which works fine but when I press a number on my keyboard (1, 2, 3 etc) I get this:

enter image description here

What am I doing wrong? I cannot type a number.

share|improve this question
1  
Specify, in your question, which number keys you are using. Most PC keyboards have at least two distinct sets of keys for generating numbers. –  JdeBP Jan 17 '12 at 17:55
add comment

1 Answer

up vote 3 down vote accepted

My guess: You are using PuTTY to connect to the server, and ee has requested it to enable "application keypad" mode, in which the numpad sends special sequences instead of numbers, which ee then misinterprets.

  • Press Ctrl+NumLock to toggle back to "normal" mode.

  • It can be disabled permanently under Terminal → Features → Disable application keypad mode.

share|improve this answer
    
Thank you very much, yeah I am using putty. –  Richard Knop Jan 18 '12 at 12:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.