Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Under Process Explorer, I noticed that System -- and occasionally Interrupts -- are taking between 5% and 20% CPU constantly, for hours on end. This is resulting in weird video playback problems. (Audio files have 'gaps' and YouTube videos have pauses in them.)

This problem has been happening for a while. Sometimes, a restart fixes it, IIRC. I also recently upgraded to a 1920x1080 monitor... But this shouldn't have any affect on audio. I also just disabled ReadyBoost (which I also got recently).

I killed PeerBlock and uTorrent, and this still continues to happen; previously, killing them was enough to get my CPU back down to ~0%.

My CPU temperature is ~55 C and my HDD is at <40 C.

System 7% and Interrupts 1%


So it is uTorrent's fault (or PeerBlock or Comodo).

System 34% and LatencyMon description

share|improve this question
2  
This is most likely related to ahrdware. Get newest BIOS, newest drivers for everything... Try out LatencyMon, it may help you narrow down the driver which is problematic. Basically someone wrote interrupt service routine that's taking way too much processor time and there are usually two ways around that: get a new driver or disable the device functionality that uses that ISR. Either way, it'll take lots of experimentation to figure out what's happening. –  AndrejaKo Jan 18 '12 at 7:29
    
Get to the cause of high cpu usage due to Interrupts how To here....msfn.org/board/topic/… –  Moab Jan 18 '12 at 15:50
1  
@AndrejaKo I tried it out and it happens whenever uTorrent runs (experience) -- LatencyMon confirms that. –  muntoo Feb 9 '12 at 7:28
    
@muntoo OK. Did you try getting the newest driver for your netwoerk card from its chipset manufacturer? Which network card do you have? Check in device manager any options for hardware processing and work off-load and experiment with them. In general, having card do as much processing as possible should speed things up, but you should try turning some of the options off too, in case something isn't working correctly at the cards side. Also, post image of available settings in device manager for it. –  AndrejaKo Feb 9 '12 at 12:14
    
@muntoo Also, once you start recording, switch to drivers tab and show us what is happening there. It should show us exactly which drivers are taking most time to do their processing. –  AndrejaKo Feb 9 '12 at 12:18

2 Answers 2

Look carefully at this picture, what the worst thing that you can spot?

That should be ndis, which stands for network driver interface specification.

Wait, what... Network, that's right:

So it is uTorrent's fault (or PeerBlock or Comodo).

So, hmm, the problem is indeed provoked by network activity. And it does something with the driver interface, that's right because firewalls add class filters to driver interfaces.

So, the correct way to proceed is to get rid of those filters, which has proven to work for me:

  1. Get rid of your Comodo firewall, PeerBlock and other network related filters.
  2. Get rid of your network card (from device manager) and remove its drivers.
  3. Shut down your computer.
  4. Remove the network card.
  5. Boot your computer.
  6. Ensure the network card is gone from the Device Manager, under the options at the top you can select to show hidden devices; remove any hidden network card devices you come across.
  7. Shut down your computer.
  8. Insert the network card again.
  9. Get the newest drivers for your network card, install them.
  10. Reboot again to make sure they are cleanly loaded.
  11. Test your software again, then consider an alternate firewall.

Been through worse issues, done the above steps to get rid of Comodo.

share|improve this answer

Drives on the IDE Bus (hard disks or CD/DVD drives) may transfer data via so called PIO mode or DMA mode. In my case windows switched back a drive from DMA to PIO which caused a lot of interrupts. Windows does this in case of permanent errors on the drive. Unfortunately it does not try DMA later again. You have to uninstall the driver on primary and/or secondary IDE channel followed by an immediate reboot (windows asks accordingly). While booting, the device is found again and the driver is re-installed using DMA (if this was the problem) or PIO (if this wasn't the problem).

share|improve this answer
1  
Erm... How is this relevant to the question? –  Tom Wijsman Oct 20 '12 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.