Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Where do I change the setting in Skype on Windows 7 for how time is formatted?

While the time is shown as 11:14 PM on Skype I would rather it display as 23:14.

share|improve this question
add comment

3 Answers

Had the same problem. Everything in Windows 7 was displaying time in 24 hour format—except Skype.

I changed "Long time" from HH:mm:ss to H:mm:ss (note capital H's), which fixed the problem. Then I changed it back to HH:mm:ss and it still displays time correct.

Skype is not as clever as it would like to be. :)

share|improve this answer
add comment

The timestamps shown next to IM messages in Skype are formatted according to the long time format you have defined in Windows' regional settings (assuming you are on Windows, you didn't specify).

In order to change them, press the start button and type "change time" which should take you to the Region and Language settings dialog. Click on Advanced settings... and on the Time tab change the Long time to something like HH:mm:ss (see screenshot below).

Note that this is a system-wide setting that will also impact other applications, for instance the way Windows displays the Last modified date of a file in Explorer.

Region and Language

share|improve this answer
    
yes, I am on Windows 7, and these settings was h:mm:ss, before installing Skype. Without tt, 'cos tt is for AM/PM. –  Newonetwo Feb 20 '12 at 17:00
    
@Newonetwo Ok, so before you installed Skype that setting was h:mm:ss. What are does it look like now? If you change it, does that also change the way the timestamps are displayed in Skype (you might have to restart Skype for those changes to take effect)? –  PersonalNexus Feb 20 '12 at 19:23
    
the same =) I try to change it to hh:mm:ss(I know that is quite the same) - nothing happens. All other dates in Windows are in 24h-format, were and are. –  Newonetwo Feb 21 '12 at 11:00
    
@Newonetwo If that is the case, I guess I'm out of ideas. Sorry. –  PersonalNexus Feb 22 '12 at 18:53
add comment

I experienced the same thing when I installed Skype for the first time yesterday, my Win7 64-bit system is set to Swedish, but Skype presented date/time in US-english format.

In my case this was an issue with the Windows registry, where the key HKEY_USERS\[user-id]\Control Panel\International\Locale was set to 00000409 (meaning US-english), instead of 0000041D which would be the correct value for Swedish. The key LocaleName was nevertheless set to sv-SE and this is what is seen in the Control Panel interface, so everything seems OK there - you have to get into the registry with regedit to see the discrepancy between the two keys.

Different applications use these registry keys in different ways, and apparently Skype relies entirely on the Locale key.

When I edited the Locale key to 0000041D and restarted Skype, it displayed date/time in the correct way.

This error is due to a bug in some Microsoft installation/deployment tools. It is described in MS KnowledgeBase article 2625165

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.