Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What's my end game :

installing SSPLUS, a PCEL extension

My config : A virtuozzo server running Linux 2.6.18-028stab069.6 (Debian Lenny ??)

What I've done :

1

pear install spplus

Deprecated: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0

Deprecated: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0

No releases available for package "pear.php.net/spplus" - package pecl/spplus can be installed with "pecl install spplus"

install failed

2

pecl install spplus

.....

4 source files, building

running: phpize

sh: phpize: command not found

ERROR: `phpize' failed

3

After some research I found that I had to install php5-dev (or devel). So, here I go

apt-get install php5-dev

apt-get install php5-dev

....

The following packages have unmet dependencies: php5-dev: Depends: libtool (>= 2.2) but it is not going to be installed E: Broken packages

4

I tried apt-get libtool but all I get is libtool 1.5.26-4+lenny1

I find on another question here to tried :

apt-get update apt-get upgrade

and re-installing libtool, but I always get the same version.

I don't really understand apt-get so I don't really know what to do

my apt/sources.list :

deb http://ftp.de.debian.org/debian lenny main contrib non-free
deb http://ftp.de.debian.org/debian-volatile lenny/volatile main contrib non-free
deb http://ftp.de.debian.org/debian-security lenny/updates main contrib non-free
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
deb http://autoinstall.plesk.com/debian/PSA10 lenny all
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.