Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My C: system boot partition needs to be bigger. Tried Acronis, EASUS, and PM within Windows but the partition could not be enlarged with either a merge with another partition or resizing with unallocated space. I launched Gparted on boot-up and the same findings. Every program does not show available space for boot partition to change. It seems it is locked. Any ideas?

share|improve this question
    
Show the world, in your question, the output of the list partition command from diskpart. People cannot clairvoyantly determine what partitions are on your hard disc and where they are. –  JdeBP Jan 18 '12 at 17:02
    
Last time this happened to me it was because the hard drive was bad and the S.M.A.R.T. data showed it. Many tools worked OK but GParted would not allow it. I remember though that the failure message that it displayed was rather vague. –  Dennis Jan 18 '12 at 19:30

3 Answers 3

Use the latest version of GParted. I used the partedmagic-dot-com version which seemed to be the most up-to-date. They have updated since I last downloaded version 11-11-11 .iso.

I was not successful resizing (shrinking) my NTFS (Win XP Pro SP2) partition with version 0.6.2 on Ubuntu 10.10, so I downloaded PartedMagic from the above website. Which was successful to a point (it worked ok, but modified NTFS to FAT32 as I describe below).

Windows NTFS partition stores a partition table at exactly the halfway point of the partition - I found out by searching for "NTFS partition physical structure" and landed at: http://ixbtlabs.com/articles/ntfs/

You might try resizing initially to a size just greater than one-half the size of the partition (in terms of MB) - as a start.

Before you do anything I recommend you read the following tutorial on using GParted and before you do anything for real: GParted partitioning software - Full tutorial at: http://www.dedoimedo.com/computers/gparted.html

While the shrinking of my NTFS partition was successful running version 11-11-11 .iso burned to a USB (PMagic.com) at: partedmagic-dot-com-slash-doku-dot-php, what happened was: after running the smaller resize (which was successfully done), it recommended that I could further shrink the partition which at that time was still an NTFS partition. I decided to log out and continue the next day. What I found out subsequently was that GParted (pmagic version 11-11-11) no longer detected my formerly NTFS partition as NTFS, but as a FAT32 partition - much to my surprise.

I have to open an account to query the forum at: forums-dot-partedmagic-dot-com in order to post a thread questioning whether this is a feature or a bug - and if a bug - how do I fix what has transpired in order to shrink my partition further - or, does it not matter?

Interestingly, my Ubuntu 10.10 version of GParted 0.6.2 still detects the partition as an NTFS partition.

share|improve this answer

Check first, that partitions you are trying to resize are unmounted, if you are doing it from linux based system.

Do not use minitool partition wizard program, it deleted me 2 partitions, while I was working with others partitions.

Do not use any freeware partitioning tools for windows. In my experience, the best tools is Gparted and other popular freeware for linux.

And backup first important data!

Also it will be more robust and fast to resize already defragmented partition that has more empty that used space.

And for hfs+ partitions the best way to work is disk utility from os x.

share|improve this answer

Is this because you do not have unallocated space behind the boot partition. Unallocated partition is required for extending partition.

Another way you can try is to use boot partition manager. All operations will be done in pre-installation environment. I guess you can not resize boot partition is because windows do not allow you to do this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.