Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to figure out why my laptop all of a sudden has no internet connection when I moved it to use a different ethernet cable. This is a wired connection. It is not the ethernet cable's problem because when I moved it to use an ethernet cable that does have internet (tested by another computer), it fails to have any internet connectivity.

I am using Windows XP and from the Network Connections window, the Local Area Connection 2's status is currently "Disabled, Firewalled". I tried to right click, and click Enable, but a pop up says "Connection failed!"

I also tried to do a repair with xpnetdiag.exe, but it fails to and just says "Consult your computer manufacturer's troubleshooting information. You can also use another computer to visit online support services. Contact your computer manufacturer for additional assistance if required."

Any ideas? I suppose my last result is to contact the manufacturer if it is a hardware problem from my laptop... :(

Thanks..

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

AFAIK "Disabled" state means that the network card is turned off. From the fact that you can't turn it on can indicate that:

  • there is a problem with the driver of the card
    • try restarting
    • try re-installing newest driver from the manufacturer's site
  • a different (but related) driver collides or is not installed correctly (in case you e.g. installed a firewall in the meantime)
  • there actually is a hardware problem with your network card

However, I'm not sure about the "Firewalled" part.

share|improve this answer
1  
Usually, Firewalled means Windows Firewall is on –  Dave M Jan 18 '12 at 20:43
    
You were right in that the network card is off. If this helps out anyone else, I am using a Dell laptop and was successful in reinstalling the driver, but had to go into the Dell QuickSet (can be found on the bottom right task bar) and go to Internal Network Card Power Management and click Always Activate on battery. I think my laptop is screwy, but this fix works. –  O_O Mar 28 '12 at 22:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.