Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have a NAS. According to the website I should be opening port 80 (for the web interface), port 443 (HTTPS), 20 and 21 for FTP and some random range for torrent downloading (I kinda don't need it, but I did it anyway).

So let's say my external IP is 80.80.80.80 and the NAS's internal IP is 192.168.1.2. Every time I browse to 80.80.80.80, it finds my NAS (as I see the icon appearing), but it suddenly redirects me to 192.168.1.2 (and as being at my work, it can't find that IP address to be valid of course).

What am I doing wrong here?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You opened the ports properly. There is no doubt about that.

The problem is the NAS links (if you inpect the link, a href of what oyu are clicking) it will be 192.168.1.2 -- Why is it doing this. Because the NAS is not looking at the CLIENT (yourself at the office) but its own IP in the code.

People can argue that is how it should be for security reasons.. But I argue- the team who wrote the website did not think about this problem.(because if they did there would be an option to rewrite client IP links instead of local ones...)

With my NAS i wrote my own website because i wanted to see other things. Basically any ADMIN links i specifiaclly set to 192.168.1.1:port because i dont want anybody changing my stuff over the internet. But when I am at home it works fine. Any links that i want to work over the internet i use a php function to find the CLIENTS IP address and write it into the a href so it will write

You can work around this problem by doing some simple things and NEVER expose your NAS webpage to the internet, ever.

  • Use Putty to SSH into your NAS and use Tunneling - its like VPN but slighlty faster and does not requiere any other ports opening except SSH. I wrote about this over here
share|improve this answer

If the IP in your browser suddenly changes from 80.80.80.80 to 192.168.1.2 it is most likely the NAS web interface that is causing trouble. It might be a faulty configuration in the NAS or a bug. Try looking for know bugs/mistakes. What kind of router do you have?

share|improve this answer
    
I am using a Linksys (WRT54G2) router. Port-forwarding worked like a charm before. –  Roel Jan 19 '12 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.