Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Bad

The Good

This is Windows 7. In System properties -> Performance options -> Adjust for best performance

It makes what I want only for the Desktop if I go into folder and try to select the files the selection rectangle is like in the first image.

How to make it everywhere?

share|improve this question
    
this is in windows 7? It uses the dotted selection in my 3rd party file manager, so it must be the explorer shell itself ?, and the new interface for it. It even uses that in the "classic" themes. –  Psycogeek Jan 20 '12 at 1:46
1  
I have always had show translucent selection rectangle off, and I just noticed this! Confirmed. –  iglvzx Jan 20 '12 at 6:14
2  
@iglvzx it seems that it is normal behaviour for the Windows 7. According to malektips.com/… and other sources –  bakytn Jan 20 '12 at 8:42

1 Answer 1

up vote 2 down vote accepted
+300

As far as I can find out, show translucent selection rectangle off used to work in Vista for both the desktop and Windows Explorer.

However, since Windows 7 the Windows Explorer ignores this setting and always uses the filled selection rectangle, no matter its setting. This is no doubt a new bug introduced in Windows 7.

Sorry to be negative, but in my opinion the most one can do is file a bug report with Microsoft as regarding this issue.

Unfortunately, there's no submit a bug report option directly. The way one does it is to call Microsoft Support and open a support request (can also be done online). If they can reproduce your issue and verify that it's actually a bug they will file a bug report.

[EDIT]

I found a way of forcing Explorer to honor the Translucent Selection Rectangle setting that is found in the registry in the key :
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
You should set the value of ListviewAlphaSelect to zero (0) to disable the Translucent Selection Rectangle.

Unfortunately this change is ignored by the list-view control of Windows 7 (DirectUIHWND). One must therefore force Windows 7 to use the old list-view control from Windows Vista.

The following article contains a registry hack which (incidentally) will accomplish this:
How to Disable Full Row Select in Explorer in Windows 7.

It links to a zip file that contains two .reg files : One effects the change and the other undoes it. I tried it inside a vanilla virtual machine and it worked for me.

I would still suggest to create a system restore point before using this hack.

share|improve this answer
    
yes that's fun. Windows 7 was released 2.5 years ago. Still hope to fix this. Even thinking about using custom Windows Explorer –  bakytn Jan 22 '12 at 10:31
    
One can still hope for Windows 8 ;) . However, Microsoft has a history of not caring about small bugs. –  harrymc Jan 22 '12 at 11:05
    
Semi official statement was that this is a bug. And since Windows 7 is in maintenance mode (it only accepts security/crash patches) so possibly this issue will never be fixed for Windows 7. WIll wait until bounty ends and will accept this answer –  bakytn Jan 23 '12 at 1:10
    
Read my edit above. –  harrymc Jan 23 '12 at 19:31
1  
The 3rd party product might still be using the old Vista list-view activex control. –  harrymc Jan 24 '12 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.