Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a USB IrDA that I got working with my IrDA printer (SiPiX compact printer A6) on the Windows side, using default 4000000 speed and 1.0ms turn-around time (in the driver config). The USB IrDA dongle is using SigmaTel chip. IR printing works using IrDA port and SiPiX driver.

I'm trying to get it working on my Linux side (same machine), especially when SiPiX driver already exists in the CUPS. I seem to be able to use standard USB FIR driver to see my IrDA and my printer, via irattach irda0 -s, and then irdadump. I'm unable to get anything from SIR with this USB dongle at all (e.g. irattach /dev/ttyS1 -s).

If FIR is good enough, I'm guessing I'll need to create a serial port of some kind from the working FIR and then addressing it from CUPS, but I got stuck here.

share|improve this question

1 Answer 1

Use SIR with module option tx_window=1.

 Once you compiled and installed your kernel module it should be loaded automatically once you plug-in the dongle the first time. Now you have to tell your machine to initialize the IrDA subsystem. In SuSE distro's this reacting on USB events is usually done via hotplug

This is very easy, too: Simply let hotplug know which script to start when plugging in the USB adapter with the appropriate .usermap-file and with that script start or stop the IrDA subsystem.
# SigmaTel STIr4200 IRDA/USB
usbirda 0x0003 0x066f 0x4200 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000


if [ -x /usr/sbin/rcirda ]; then
    if [ "${ACTION}" = "add" ]; then
        /usr/sbin/rcirda start && exit 0
        /usr/sbin/rcirda stop && exit 0

You can also download this as a .tar-archive.

/usr/sbin/rcirda is a link to the script /etc/init.d/irda that is installed by SuSE with the irda-package. It will do a simple irattach-command:

/usr/sbin/irattach ${IRDA_PORT} -s >/dev/null

If you are using the SuSE script you should be sure that IrDA is configured to use the module you installed and not a serial port:

## Path:        Hardware/IrDA
## Description: Settings for the infrared device
## Type:        string("",/dev/ttyS1)
## Default:     /dev/ttyS1


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.