Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently switched distros to fedora (was looking for the most recent version of eclipse being supported, something I wasn't getting from Debian), and in trying to get synergy set up again, I've been having an issue where my synergy server is refusing the connection from my macbook.

My synergy.conf file:

section: screens
    client1:
    server:
end
section: aliases
    client1:
        macname
    server:
        linuxname   
end
section: links
    client1:
        left = server
    server:
        right= client1
end

My synergys command:

synergys -f -c /path/to/synergy.conf

My synergyc command:

synergyc -f linuxname

Both computers can ping each other, and on the linux computer I've used

telnet localhost 24800

which confirms that synergys is running (also ps -Af | grep synergys).

On the mac, when I try to do

telnet linuxname 24800

I get the message

telnet: connect to address ip.of.linux.box: Connection refused
telnet: Unable to connect to remote host

$ sudo netstat -pant | grep 24800
tcp 0 0 0.0.0.0:24800 0.0.0.0:* LISTEN 22727/synergys

Both versions of Synergy report themselves as 1.3.7, protocol 1.3 .

I'm at a loss. Anyone got a bright idea or two?

share|improve this question
    
On the linux box, can you run sudo netstat -pant | grep 24800 and post it here? –  Paul Jan 21 '12 at 22:29
    
tcp 0 0 0.0.0.0:24800 0.0.0.0:* LISTEN 22727/synergys –  Chaosphere2112 Jan 21 '12 at 22:34
add comment

2 Answers

As you are getting connection refused rather than a timeout, I suspect it is an issue with host access control rather than a firewall issue. If these files exist, please make sure that the deny file do not contain any blocks:

 /etc/hosts.allow
 /etc/hosts.deny

So comment out any lines containing ALL

share|improve this answer
    
There's nothing in either file besides "# hosts.allow This file contains access rules which are used to # allow or deny connections to network services that # either use the tcp_wrappers library or that have been # started through a tcp_wrappers-enabled xinetd. # # See 'man 5 hosts_options' and 'man 5 hosts_access' # for information on rule syntax. # See 'man tcpd' for information on tcp_wrappers # ~ " –  Chaosphere2112 Jan 21 '12 at 22:57
    
host.conf does say "multi on" –  Chaosphere2112 Jan 21 '12 at 22:58
    
Synergy does not use tcpwrappers; the hosts.allow/.deny files are not being used. host.conf contains DNS resolver configuration and is completely irrelevant. –  grawity Jan 21 '12 at 23:00
add comment
up vote 0 down vote accepted

Actually, this was a firewall issue. I guess I was firewall-less on my previous (debian) installation (or the port was already open). I opened port 24800 using system-config-firewall, and it just plain worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.