Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some background

The PC in question is a P4, custom built with an Intel D945PVS motherboard.

I built it back in 2006 and its hard drive died once, and I replaced it with another hard drive of the same type. (A maxtor 250GB SATA)

The problem

I wanted to upgrade to an SSD, so I unplugged the old hard drive, plugged in the SSD, and booted my usb stick (with unetbootin) and installed Debian.

Installation completed, but on reboot, PC reports that no bootable media could be found.

Drive can be seen in BIOS. BIOS drive is set to ACHI, although changing it to IDE or RAID did not help.

I bought a 500GB mechanical drive (seagate) just for kicks, and threw it in. Same Debian install, still won't boot int it.

I know the installation media is not at fault as I've used it to install Debian to other PCs in the past, both before and after I tried it on this particular PC.

I plugged the old drive back in, and it spins up and loads Ubuntu (the OS that was on it before) perfectly.

What could be wrong?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

It may well be that your Debian installer did not properly set up the SSD as a bootable device.

Not all BIOS implementations are the same and it may be that the way it handles the USB device is handled slightly differently and so you have this problem. I would doubt that the system has troubles with using drives others than the original, this looks to me to be an oddity of your BIOS.

It working fine on other machines does not mean it will work properly on every machine.

Try booting and installing from a CD and see if that works.

share|improve this answer
    
Or use the installation media to enter rescue/recovery mode and check the partition type scheme (should be MBR) and manually reinstall your boot loader to the MBR. –  billc.cn Jan 21 '12 at 22:19
    
Mokubai, thanks for the answer. You're right, as the problem only occurs with this machine, it makes sense that there is a problem with the mobo detecting whether or not a drive is bootable or not. You are also right in that the Debian installer by default does NOT make any partitions with the bootable flag flagged. This particular PC is also the only PC with an Intel mobo, the rest are ASUS. –  Julian H. Lam Jan 21 '12 at 22:25
    
I'll reformat and check back with you tonight. –  Julian H. Lam Jan 21 '12 at 22:26
    
Seems to have worked, thanks again for your help. –  Julian H. Lam Jan 22 '12 at 17:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.