Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox doesn't focus on the Awesomebar when creating a new tab automatically (similar to what Google Chrome does), or at least, my installation doesn't.

Does anyone know of anyone a way of doing this?

Thanks!

EDIT: I might have been vague above so here goes: When I open a new tab, Google Chrome autofocuses the typing cursor on the omnibar, so I can start typing site/search straight away.

With Firefox this doesn't happen. If I set the homepage to blank page, and create a new tab, nothing is focused by the typing cursor, if I have anything else as the homepage, it focuses on different elements on the website (depending on the website of course).

I want to replicate something similar like Google Chrome, i.e. if I open a new tab/window, the cursor is placed in the Awesomebar so that I can start typing straight away.

At the moment I have to press Ctrl + L/Alt + D or click on the awesomebar before I can start typing.

share|improve this question
    
Could you post a screenshot of this? I dont understand –  Simon Sheehan Jan 22 '12 at 0:08
    
I have just edited the question to be (hopefully) less vague. –  Hosh Sadiq Jan 22 '12 at 0:20
    
Which operating system? If there are no such extensions, I can write of an AutoHotkey script for Windows. –  iglvzx Jan 22 '12 at 0:38
2  
So I found out it is "Mar Mod" that seems to be the culprit. When it's enabled it doesn't autofocus on the awesomebar, when it's disabled, it works fine. And I'm using Windows 7 x64 with Firefox 9.0.1. –  Hosh Sadiq Jan 22 '12 at 0:46

1 Answer 1

up vote 1 down vote accepted

Okay so it seemed that others were having the same problem, so the author has come up with a temporary fix till the next version:

  1. Go to C:\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\[profile]\extensions
  2. Rename MarMod@mario.ar.xpi to MarMod@mario.ar.zip and extract it's contents.
  3. Edit the file content/newtab.js by adding if (isElementVisible(gURLBar)) { gURLBar.select(); gURLBar.focus(); } after the line gBrowser.selectedTab = newtab;
  4. Save the changes, zip the whole thing up again, and rename the zip back to MarMod@mario.ar.xpi and replace it with the original xpi located profile folder.

After a restart it should be fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.