Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's my setup; I'm a router newb so I don't completely understand the intricacies of my configuration - but suffice it to say, I've set it up this way so that anyone who's connected to Router A can't ping anyone on Router B but anyone on Router B can ping anyone on Router A as well as getting an internet connection.

Router A:

  • Is the ISP's provided router.
  • IP: 192.168.1.1
  • Subnet: 255.255.255.0
  • DHCP
    • Start IP: 192.168.1.2
    • End IP: 192.168.1.12
    • Primary DNS: 192.168.1.1
    • Default Gateway: 192.168.1.1
    • DNS Proxy Enabled (don't know what this does exactly, it's on by default)
  • LAN port 1 connects to WAN port on Router B
  • Has it's own wireless network (for guests to use)

Router B:

  • Is my own router with Tomato firmware loaded.
  • IP: 192.168.0.0
  • Subnet: 255.255.255.128
  • Static DNS: 192.168.1.1
  • DHCP
    • Start IP: 192.168.0.1
    • End IP: 192.168.0.126
  • WAN port connected to LAN port 1 on Router A
  • Has it's own wireless network (for employees to use)

So if I were to connected to Router B I'd have access to all the computers that are also connected to it. I'd also be able to connect to devices connected to Router A. Devices on Router A however do NOT have access to any devices on Router B. The problem I'm having is that some smart phones like the iPhone can't ping devices on Router A (and thus can't connect to the internet). My laptop and other computers work just fine though. When the iPhone is connected to Router A, the internet works fine as well.

Looking at the settings the iPhone gets, they all seem to match what my other computers get. The DNS and Gateway are both 192.168.0.0 (same as other computers). I'm not sure what the deal is.

On a side note, my Windows Phone 7 seems to work OK on the private network. My brother's Android - like the iPhone doesn't work.

share|improve this question
1  
Are you sure you have Router B's IP right? 192.168.0.1 seems much more likely. –  freiheit Jan 21 '12 at 22:36
add comment

migrated from serverfault.com Jan 22 '12 at 9:38

This question came from our site for professional system and network administrators.

1 Answer

up vote 2 down vote accepted

192.168.0.0 is not a host address on the 192.168.0.0/25 network - an all-zero host address is invalid except in some very specific circumstances (using a /31 mask for router peering subnets).

In short: this shouldn't work, and I'm shocked that it's partially working for you at this point.

Change the router's address to a valid one, and this should resolve the issue. For some further reading on subnetting, see this question.

share|improve this answer
    
+1 as I can't knock your reply, but just thought I would note I have on a few times seen crazy router misconifguations that shouldn't work but do somehow (to varying extents). –  Robin Gill Jan 22 '12 at 4:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.