Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I experienced a very slow start-up. Today I got a BSOD. I am using Windows 7, x64, on a Toshiba Satellite A660-11M and have not tinkered with the hardware recently (changed HDD a few months ago). Here are the dump and sysdata files from the BSOD.

This is how it all happened:
Yesterday: I turn machine on, loads, boots-up to login-screen. I enter my password, and here comes the slow part. Windows Desktop fades in, but I am unable to do much (screen partially frozen). Then, after 1-2 minutes, everything responds again and I get a pop-up from AVG mentioning an error on its behalf (sorry, forgot exactly what it said).

Toady: I turn machine on, Windows boots-up to login-screen, I enter my password and go make some coffee; and when I come back (assuming it took me a couple of minutes) the "Welcome" loading screen with the little loading symbol is still present. After waiting a while, I realize the machine is not responding and shut it down by force (continuously pressing the on/off button). Then I start the machine again, loads up to login-screen, I enter my password - screen freezes and after a few seconds, BSOD.

On my next attempt (after the BSOD) Windows did manage to boot-up completely. However, once in Desktop, I still experienced a very slow performance. I got the usual "Windows did not shutdown properly" message, from which I saved the .DMP and .SYSDATA files (see above).

As the title connotes, I feel this is related to AVG 2012 Free Edition. Because of the peculiar error message I received yesterday, and because today, after the BSOD, the Windows 7 Action Center flag is showing up in the system tray. It says "AVG Anti-Virus Free Edition 2012 reports that it is turned off". However, I do see the AVG icon on the system tray.

So this all seems a bit fuzzy to me. I hope the dump and sysdata files allow you to help me. I would really, really appreciate it. Please let me know if I missed any relevant information, and I will add it ASAP. Thank you!

UPDATE 1: I started Windows in Safe Mode with Networking, and the problem seemed solved. Windows booted fine, Desktop loaded fine. No freezes, no unresponsive Windows Explorer. Because of this, I wondered if the issue could be caused by something else than hardware. I ask this because I am not fully certain as to how Safe Mode works, but from what I know, it still uses the same hardware (just not some drivers). So, again, is there a chance this is not HDD (or other hardware) related?

UPDATE 2: As recommended by user Moab, I ran the hard-drive's diagnostics tool provided by the manufacturer. This tool allowed me to run a SMART test first, which is a quicker, smarter, sort-of "preview" test. The result was that "too many problems were found and thus the diagnostics tool has ended". I then ran the full test overnight, which resulted in this.

I am still looking for a solution and would truly, truly appreciate your help!
Thank you!

share|improve this question
    
Are you able to boot and remove AVG? See If that helps –  Simon Sheehan Jan 22 '12 at 14:12
    
I just removed AVG. When uninstalling I got an error (0xC0070643 - forums.avg.com/us-en/…). As recommended on a forum post, I used the AVG Removal Tool to uninstall AVG - and it worked. Throughout that tool's process, I had to restart my machine, and it also worked. I am now looking into other AV possibilities, or maybe, just a re-installation of AVG. Any recommendations? –  cr0z3r Jan 22 '12 at 14:55
2  
Microsoft security essentials is really good and lightweight windows.microsoft.com/en-US/windows/products/… –  Simon Sheehan Jan 22 '12 at 15:00
    
Avast is also good. avast.com –  Adam543i Jan 22 '12 at 21:51
add comment

1 Answer

up vote 2 down vote accepted

Dump analysis shows the bsod to be an I/O error of the hard drive, run the hard drive manufacturers diagnostics on the drive just to be sure the drive is not failing. Could be a one time error also. .

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e) This is a very common bugcheck. Usually the exception address pinpoints the driver/function that caused the problem. Always note this address as well as the link date of the driver/image that contains this address. Some common problems are exception code 0x80000003. This means a hard coded breakpoint or assertion was hit, but this system was booted /NODEBUG. This is not supposed to happen as developers should never have hardcoded breakpoints in retail code, but ... If this happens, make sure a debugger gets connected, and the system is booted /DEBUG. This will let us see why this breakpoint is happening. Arguments: Arg1: ffffffffc0000006, The exception code that was not handled Arg2: fffff88000c110e9, The address that the exception occurred at Arg3: fffff88007a60778, Exception Record Address Arg4: fffff88007a5ffd0, Context Record Address

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.

FAULTING_IP: CI!MinCrypK_GetCertAlgId+45 fffff880`00c110e9 66394104 cmp word ptr [rcx+4],ax

EXCEPTION_RECORD: fffff88007a60778 -- (.exr 0xfffff88007a60778) .exr 0xfffff88007a60778 ExceptionAddress: fffff88000c110e9 (CI!MinCrypK_GetCertAlgId+0x0000000000000045) ExceptionCode: c0000006 (In-page I/O error) ExceptionFlags: 00000000 NumberParameters: 3 Parameter[0]: 0000000000000000 Parameter[1]: 00000000021c3804 Parameter[2]: 00000000c0000185 Inpage operation failed at 00000000021c3804, due to I/O error 00000000c0000185

CONTEXT: fffff88007a5ffd0 -- (.cxr 0xfffff88007a5ffd0) .cxr 0xfffff88007a5ffd0 rax=0000000000000200 rbx=0000000000000000 rcx=00000000021c3800 rdx=0000000000001b80 rsi=0000000000000000 rdi=0000000000000000 rip=fffff88000c110e9 rsp=fffff88007a609b0 rbp=0000000000000000 r8=000007fffffeffff r9=fffff88007a60aa8 r10=0000000000000000 r11=0000000000000000 r12=fffff8a00000bec0 r13=0000000000000000 r14=0000000000000000 r15=fffff80000b96080 iopl=0 nv up ei pl zr na po nc cs=0010 ss=0018 ds=002b es=002b fs=0053 gs=002b efl=00010246 CI!MinCrypK_GetCertAlgId+0x45: fffff88000c110e9 66394104 cmp word ptr [rcx+4],ax ds:002b:00000000021c3804=???? .cxr Resetting default scope

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

PROCESS_NAME: System

CURRENT_IRQL: 0

ERROR_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.

EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: 00000000021c3804

EXCEPTION_PARAMETER3: 00000000c0000185

IO_ERROR: (NTSTATUS) 0xc0000185 - The I/O device reported an I/O error.

BUGCHECK_STR: 0x7E

EXCEPTION_STR: 0xc0000006_c0000185

FOLLOWUP_IP: +45 00000000`021c3804 ?? ???

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: hardware_disk

IMAGE_NAME: hardware_disk

DEBUG_FLR_IMAGE_TIMESTAMP: 0

STACK_COMMAND: kb

FAILURE_BUCKET_ID: X64_0x7E_IMAGE_hardware_disk

BUCKET_ID: X64_0x7E_IMAGE_hardware_disk

share|improve this answer
    
Woah, thank you so much for that. I have to admit I am not completely certain what to do with this information, though. Would you agree that the force shutdown caused that somewhat delayed BSOD? In any case, thank you a million times again. –  cr0z3r Jan 22 '12 at 22:29
    
No, its a hardware error. –  Moab Jan 23 '12 at 0:52
    
I understand, but as you said "I/O error of the hard drive", I thought it could have been related to the forced shutdown. Please correct me if I am wrong. –  cr0z3r Jan 23 '12 at 16:57
    
I am getting really frustrated and scared. This has happened again (no BSOD, but freezing). My system is taking too long to get into Windows. It seems the booting is not the issue, but the actual "start-windows-and-show-me-my-desktop" is. Today, everything seemed to be working right, even the part where my Desktop fades in. Still, once my Desktop was visible, I decided to wait a while and give my PC a few minutes of breath. Then, as I hover my mouse over the taskbar, I get the loading-ring symbol. I attempt to click anywhere, and Explorer freezes. Only after forced off/on am I back here. –  cr0z3r Jan 24 '12 at 14:32
    
Moab, thank you again. There is one thing worth mentioning: I am, as we speak, on Safe Mode with Networking, and Windows loaded perfectly fine. Previous to this, I tried starting Windows normally (loading, loading, loading, attempt to right-click, keeps loading approx 10mins; I just gave up and restarted and here I am). Could this somehow indicate it is NOT merely related to the HDD? –  cr0z3r Jan 25 '12 at 15:41
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.