Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu and XAMPP on my computer but when i start the web server and go to htt://localhost/webname (webname is the folder name inside htdocs) i receive error 403.

There .htaccess inside webname is the following:

# Created on: 03/01/2012
# Author: **********

# Redirect every request to index.php
RewriteEngine on 
RewriteBase /
RewriteRule ^$ /webname/public/index.php
RewriteRule ^about/?$ /webname/public/about.php
RewriteRule ^changelog/?$ /webname/public/changelog.php
RewriteRule ^home/?$ /webname/public/home.php
RewriteRule ^friends/?$ /webname/public/friends.php
RewriteRule ^(\w+)/?$ /webname/public/home.php?user=$1  
RewriteRule ^login/?$ /webname/public/index.php?show=login
RewriteRule ^signup/?$ /webname/public/index.php?show=signup
RewriteRule ^profile/(\w+)/?$ /webname/public/profile.php?user=$1

# Rewrite www.webname.com -> webname.com
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

# Disable directory listing for all the subdirectories
Options -Indexes

On Windows everything works fine but on Ubuntu i keep receiving this error.

Thanks for helping.

share|improve this question
    
Does it work if you go to localhost/webname/public/index.php directly? Does the user running the webserver (www-data usually) have access to htdocs/webname ? –  Paul Jan 22 '12 at 21:25
    
No, it's not working either. –  ShadowBroker Jan 22 '12 at 22:06
    
On Windows you don't really have 'permissions', so you'll never get a 403 (Forbidden) unless you explicitly serve it. –  w3d Jan 22 '12 at 22:40
    
@MaterMorbi There are two questions in that comment. Permissions? –  Paul Jan 23 '12 at 3:42
    
I figured out it was probably a permission problem, anyway as soon as i can will let you know. –  ShadowBroker Jan 23 '12 at 8:33

1 Answer 1

up vote 0 down vote accepted

It was a problem of permissions. I just needed to change them to solve it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.