Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the Apache on my home Linux computer as a temporary server to share a few files between some friends. As such I just want a directory listing for these files, along with the sub-directories. I have the indexes option in the directory paramater, and the directory is viewed. Problem is, only one sub-directory is viewable, while the others are not listed. I have the permissions and ownerships of all files and directories the same, but nothing changes. And if I try to force into the hidden directory, I get a message about not having the necessary permissions. Any help here?

Directory directive from conf file:
    <Directory />
    Options Indexes FollowSymLinks
    AllowOverride None
    </Directory>
Permissions of Directory:
    drwxr-xr-x.  5 apache users 4096 Jan 22 17:17 DND
    drwxr-xr-x. 11 apache users 4096 Jan 16 08:16 Pathfinder
    -rwxr-xr-x.  1 apache users  119 Jan 19 17:30 README

Pathfinder and everything in it show up, and README only works when I push it through the URL. DND doesn't show, nor does it work when I push it through the URL.

share|improve this question
    
You need to provide your Apache config, and possibly directory permissions. I think this is why you were downvoted. –  user3463 Jan 23 '12 at 5:01
    
Sorry about that. <Directory /> Options Indexes FollowSymLinks AllowOverride None </Directory> If there is anything else needed, I'll post another comment. –  psion Jan 23 '12 at 5:17
    
Please edit your question to put the configuration in there. We'll need the config as well as the output of the directory listing where the permissions are affected. –  user3463 Jan 23 '12 at 5:23
    
Run an ls -l in the relevant directory. –  Christian Mann Jan 23 '12 at 5:24
    
drwxr-xr-x. 5 apache apache 4096 Jan 22 17:17 DND drwxr-xr-x. 11 apache apache 4096 Jan 16 08:16 Pathfinder -rwxr-xr-x. 1 apache apache 119 Jan 19 17:30 README Pathfinder is the only directory that shows up, and all the files and sub-directories show up. The README file and DND folder do not show up. Forcing README works, but not DND. –  psion Jan 23 '12 at 5:32

1 Answer 1

I have the same problem on a hosted solution, so I don't have the access to the "master" Apache config files - although I'm allowed to put .htaccess in my subfolders, and allow Options +Indexes there. However, even when I do so, files called README do not get listed - while files named Readme do.

This tells me that probably README is disabled somewhere in the top-level Apache setup, and probably via IndexIgnore; the problem with that seems to be:

Re. Can htaccess restore default indexing - PHP Server Side Scripting forum at WebmasterWorld

Once you setup IndexIgnore you cannot override it from the sub-folders. Try using order allow,deny for it.

... and I gave this a try:

Options +Indexes
<Limit GET POST>
  order deny,allow
  deny from all
  allow from all
</Limit>
<Files "README">
  order deny,allow
  deny from all
  allow from all
</Files>

, but it seems not even that helps with a file named README - at least not with the limited config possibilities I have. Another thing is that there is a ReadmeName attribute for apache (e.g. apache2 - Change default ReadmeName in Apache - Server Fault); which could also cause trouble? Also similar question: http - Apache do not show README.TXT files in directory listing. How can i enable it? - Stack Overflow

Anyways, the quick fix for me is to rename the file from allcaps README to mixed caps...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.