Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Win 7 Pro, 64 bit, on Dell Laptop. I use Suspend to RAM and Resume all the time, often 5-6 times a day. I rarely if ever shut down.

Recently I noticed that upon resume, I get screen that my account is Locked, and I need to click or hit enter to get a password box to login.

Prior to this, it would always resume to the password box, no need to click.

I have no issue with the password prompt, I like that since it slows someone down who finds my laptop (For the amount of time it takes to boot to a Linux ISO..).

I am curious what might have caused this change from just resuming to a password prompt, to now resuming to a screen saying Account Locked, click, and then password prompt. Any thoughts? I get suspicious when common behavior changes suddenly.

Edit: And then a week later it stopped doing it! Even stranger.

share|improve this question
    
    
@sblair Nope, I am not asking how to turn off the login, I want that to remain. Rather why did the behavior change suddenly on me. That always makes me wonder. –  geoffc Jan 23 '12 at 16:16

2 Answers 2

  1. Press windows key
  2. Type "power"
  3. Click Power Options
  4. Click "Change Plan Settings" under the currently selected plan
  5. You will land up on this screen

enter image description here

  • Change "Require password....." to "NO"

Sometimes a Logon screen appears before the password screen, this usually happens if some network settings have changes, eg Connecting to a Domain.

Using groupPolicyEditor is very power and changing the wrong things can lock down your computer. Please consult Microsoft for more details.

  1. Click Start, type gpedit.msc, and then press Enter. This opens the Local Group Policy Editor with the top-level Local Group Policy object open for editing.
  2. In the editor, expand Local Computer Policy, Computer Configuration, Administrative Templates, System, Logon.

Here you will find logon specific options to your computer. I hope it can help yout out. Sometimes these changes do not affect anything because they are governed by the Domain Group Policy.

enter image description here

share|improve this answer
    
Oops, maybe I was not clear enough, I will go back and clarify the question as well. I do not mind logging in. What is different is that the before, I resumed to a password prompt. Now I resume to a screen showing account locked, click, and then at a password prompt. –  geoffc Jan 23 '12 at 14:11
1  
Oh, i think that is in Group Policy Editor, and usually shows up when you connect to a domain, or change some network settings.. let me crunch the numbers for you.......please wait....... –  ppumkin Jan 23 '12 at 14:14
    
Still no matching setting that I see, all are not configured. I am wondering what specific policy might apply this change. –  geoffc Jan 24 '12 at 1:04

There are several possible answers to why the behavior could have changed. However, most of them depend on your own system and can not be known of confirmed by others.

  1. Some program could have changed the setting. This is entirely up to you to determine since only you know what programs you have installed, configured, or updated recently.

  2. A recent Windows Update changes the default setting. Windows XP SP2 forcibly changed a lot of settings once installed in order to make systems more secure. It is possible that a recent Windows Update (or Dell update if such a thing applies) changed such a setting. Of course if that were the case, one would likely find multiple people inquiring about the same thing since the update. However, the only relevant hit in the first dozen or so results is your question here, so presumably either it is specific to your system, not enough people have updated yet, not enough people have noticed and/or complained yet, or not enough people care.

  3. Have you changed any power policies? Are you leaving it suspended longer than before? Normally, it goes into standby after a while, but after an even longer period of idling, it will hibernate and shutdown. Perhaps you changed some of the power settings not realizing that it will affect what happens on resume.

  4. Another option is the screen-saver. Have you changed that? Open the screen-saver selection dialog and examine the On resume, display logon screen box; perhaps you changed that.

Whatever caused it in the first place could also be responsible for its reversion (a later update reverted the setting or you change the power/screen-saver setting again).

share|improve this answer
    
Good ideas all of them, I considered them all. Only thing applied in that time frame is Adobe update, but no reboot yet. Windows Update is nagging me, need to do those. No programs installed recently. No Screen saver changes, and no difference in suspend/resume patterns. Happened when I shut down on the bus and resumed when I got in the house 10 min later, and when I shut down for the night and resumed in the morning. Odd. And now it stopped. Odder. –  geoffc Jan 27 '12 at 12:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.