Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a layer in Photoshop with multiply on, when I however save to web it loses the blending mode.

How can I keep multiply or achieve the same effect in another way?

share|improve this question

migrated from stackoverflow.com Jan 24 '12 at 7:07

This question came from our site for professional and enthusiast programmers.

2  
stackoverflow is for programming questions –  pivotnig Jan 23 '12 at 8:07
    
I thought maybe you guys could tell me if this could be done with code. –  Jonas Jan 23 '12 at 8:46
1  
You need to flatten the image before you save it. This cannot be done with code or via any other way. Just save a copy. Flatten the image. And then save it. It will look exactly how you imagine in any format, PNG, Jpeg, GIF, TIF. Won't matter. –  Django Reinhardt Jan 23 '12 at 12:50
    
If you're developing on the iPhone, this could be of use: stackoverflow.com/questions/3679399/… –  Django Reinhardt Jan 23 '12 at 12:54

5 Answers 5

Here is one thing you can do.

  1. Copy the image you want to multiply. (CtrlA and CtrlC)

  2. Make a new 'Black' color layer and click 'add mask'.

  3. alt-click the Mask icon, so that you can enter to mask edit mode.

  4. Paste your 'multiply' images in the mask (b/w) , and then invert it.

  5. You will have a black layer with your multiply material masked.

  6. You can adjust opacity of that layer to find best looking image. (30~40%?)

  7. If you save it as transparent PNG file, you are done.

It is not perfectly same with 'multiplied image' , it will be somewhat dimmed, not that vivid enough, but it is quite useful when you need normal images or textures to apply on top of something.

share|improve this answer
    
I'm not sure if that's what the original question was asking, but that's exactly what I was searching for when I came to this question. –  user8783 Aug 16 '12 at 22:38
    
This answer is exactly what I was looking for too. Very nice method! –  Joseph Marikle Oct 23 '12 at 17:40
    
Thanks for this answer, it really help me :D –  Ariona Rian Dec 19 '13 at 4:34

Blending modes are not supported by PNG. All you get is alpha transparency. If you want something blended with the background, blend it in photoshop first, and save the flattened image.

share|improve this answer

There's a simple solution for this:

  1. Choose the layer
  2. Click fx in the layers tab
  3. Choose "Blending Options"
  4. Start dragging "This layer"'s right-most arrow to the left
share|improve this answer

If you have multiple layers, select all your layers and then convert it to a smart object by clicking right and then 'Convert to smart object'.

Then rasterize the layer by clicking right and select 'Rasterize layer' and save it as a PNG. This must do the trick!

share|improve this answer

I was just having the same issue. What worked for me was going to "fill" in my layers and adjusting it from 100% to 0% then saving the png. Hope you figure it out!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.