Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My configuration is -- Linux (as host) using VirtualBox with 3 virtual machines -- all Windows: XP, Vista, Windows 7. All virtual disks are on the same partition, all worked fine until today.

Today XP and Vista works, but for Win7 -- VB disables the start. So it is not the case, I start virtual machine and it crashes, but I cannot even start it, because start button for it is disabled. Virtual Box shows no info why.

What's more when I try to change any settings I get obscure message saying

Failed to save the settings of the virtual machine to .

Please note the empty space before period. Maybe some configuration file was lost...

Anyway, the question is: how to diagnose such problem as this one? I.e. how to find the source of the problem?

share|improve this question
I think it is referring to the current (for it) directory, which is indeed called ".". – Andrew J. Brehm Jan 24 '12 at 17:42
Did you move any files or do a disk cleanup? – skub Jan 24 '12 at 18:19
@Andrew J. Brehm, you can be right, but my guess is, something went empty, and this empty place is place for the name of something. – greenoldman Jan 24 '12 at 18:28
@skub, nope, nothing like this, all vdis are in place, I can see all the settings, change them (no save, as I described), superficially, everything is just fine. – greenoldman Jan 24 '12 at 18:29
up vote 0 down vote accepted

Old good restart of entire machine helped, but I still have no clue what was the problem.

Update: there could be a cause -- when VB detects newer version it nags you all the time about installing newer version. However if you run virtual machine, and this dialog does not show (and it should), then VBox could end up with some weird state -- the virtual machine is not really started, but you cannot start it. Dialog is not shown, so you have no clue what happened.

For now it is my best guess.

I am marking this as solved (because it solved the issue for me), but if you have an idea, please add your answer as well -- thank you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.