Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I woke up today to find that my internet wasn't working. I checked all the cables, and everything was connected, I tried to connect to my router @ 192.168.1.1 . It didn't connect. I checked the cables over again, I restarted the router, I restarted my computer, nothing was working. I ran ipconfig on the command line, and it said the subnet mask was 255.255.0.0. I've never known what this is, but every time I've seen it, it's always been 255.255.255.0, so I opened up my network bridge and set it manually.

Voila! I was able to connect to my router. No internet access yet, but I could also connect to the modem. What was missing was the DNS servers. When I set the subnet mask manually, I had to set everything else manually too. I didn't know any off hand, but I had remembered that when I ran google's DNS benchmarking tool, its tertiary choice was the address of my router. I don't know what this means exactly, but I put it in and it worked.

How does having my router as a DNS server work? Is it using its cache, or is the router using the dns servers that would have been used if I left my computer on automatic? Also, why was my computer saying the subnet mask was 255.255.0.0? Can I prevent this without setting everything manually?

Setup: I'm running Windows 7 Ultimate x86 I'm connected directly to an Actiontec (192.168.1.1) router. The Actiontec is connected to a Linksys (192.168.1.2) The Linksys is connected to the TW Cable modem.

share|improve this question
1  
Can you switch the adapter back to DHCP and post the results of the 'ipconfig /all' command? I'm assuming your DHCP server is configured incorrectly. –  Jim G. Jan 24 '12 at 20:46
add comment

2 Answers

up vote 3 down vote accepted

As Jim G said, a router typically forwards lookups to the IP of the DNS server it is configured for - To add... The benefit of this is that devices can register themselves in DNS so you can access via hostname - this would not work if you only used your ISP's DNS (excluding Netbios/similar).

As for the netmask... networking 101 time!

a netmask literally masks everything before it... For example,

255.255.255.0 can be:

XXX.XXX.XXX.YYY

In the same way as:

255.255.0.0 can be:

xxx.xxx.YYY.YYY

What I mean by this is, the subnet just defines what is on your own network, anything that isn't, requires you to go through the router. By using the range 192.168.1.x on a /24 (255.255.255.0) subnet, simply means that anything from 192.168.1.1-192.168.1.254 is on YOUR network, anything else has to go through the gateway.

By changing the subnet to a /16 or 255.255.0.0 simply means that your network is 192.168.0.0 - 192.168.254.254, but, as these are all private addresses, it really shouldn't make that much difference in a home network.

As to why it suddenly changed, and the fact you are using a bridge, all I can think is that it was either an update to the router/similar that caused problems, or a driver update on your machine.... but, it is an odd one.

share|improve this answer
    
Did you mean 255.255.0.0 as /16? –  user1125620 Jan 24 '12 at 21:17
    
@user1125620 Corrected! Sorry... Long day at work! –  William Hilsum Jan 24 '12 at 21:29
add comment

In regards to using the router's IP as a DNS server, all it does is forward requests to the DNS servers it is configured for (usually your ISPs DNS servers).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.