Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I compiled a .tex file in TeXworks for Windows 7 that had a graph in it, so I had to install the TikZ library for LateX.

Afterwards, all compilations are failing. The TeXworks console displays

texify.exe: Permission denied: myFile.log
texify.exe: Data: myFile.log

Strangely, I do not have the pdf document open in other programs such as Adobe Acrobat. I tried closing and reopening TeXworks to no avail.

How can I grant TeXworks permission to compile my .tex file?

share|improve this question
    
sounds a bit like a problem with your admin account, maybe those logfiles were created when UAC made you admin in the installation process and you ran tex as admin afterwards? have you tried removing them? – Baarn Jan 25 '12 at 3:50

Start Explorer, go to directory with that file and delete the log file. After that try again.

share|improve this answer

I just had the same problem. I tried terminating the processes "winedit" and "pdflatex" from the Task Manager and restarted winedit. Compiled the .tex file again. It worked. I think this error occurs because the pdflatex process is still running so new instance cannot run during that. Just terminating "pdflatex" process will also work.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .