Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to delete Keychain stored in System.keychain folder on Mac. I tried the following,

security delete-keychain Keychain_name

but got the following error:

The specified keychain could not be found

How can I remove the keychain? When it didn't work I tried giving the path where the keychain is stored

security delete-keychain Keychain_name /Library/Keychains/System.keychain

But even then I am getting the same error message.

I want to delete it as I'm developing applications, some of the information is stored as such. If i try to delete a single item it gives the above error.

However, When I used the following command

sudo security delete-keychain /Library/Keychains/System.keychain 

it deleted the entire System.keychain.

Where am I going wrong in deleting single item from system.keychain?

share|improve this question
    
Try it just by specifying system.keychsin, not the full path. And your question asks about deleting the entire keychain, not a single item, therefore the question. –  Daniel Beck Feb 1 '12 at 8:23

1 Answer 1

up vote 1 down vote accepted

Let's go over the terminology:

System.keychain and login.keychain are keychains. These contain keychain items like password items and secure note items.


security delete-keychain deletes an entire keychain. That's what my first comment was about: You usually do not want to delete the System keychain, including all its entries. You use this if you create your own keychains for specific uses.

security delete-keychain "/Users/danielbeck/Library/Keychains/Test.keychain"

Use security delete-generic-password, security delete-internet-password, or security delete-certificate, depending on the kind of item you want to delete, instead.

The following command deletes an item, e.g. a Secure Note, named note from the specified keychain Test2.keychain:

security delete-generic-password -l note "/Users/danielbeck/Library/Keychains/Test2.keychain"

For information about the options that allow you to specify which items to delete, see man security.

share|improve this answer
    
Thanks for your reply it was very helpful...but i got another problem when i use the delete command in terminal it succeeds but when i try to delete it using script it is not getting deleted –  chitnisprasanna Feb 7 '12 at 11:00
    
@chitnisprasanna I suggest you create a new question about that, providing much more information. What kind of script, the exact command you're executing, how others can replicate the issue you're experiencing, etc. –  Daniel Beck Feb 7 '12 at 11:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.