Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to install the 32bit gcc because i get this error:

libgcc_s.so.1 must be installed for pthread_cancel to work Aborted

I try this:

apt-get install lib32gcc1

Does not find the package

I also try this:

apt-get install ia32-libs ia32-libs-gtk

Does not find either

What I can do?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You have not specified the architecture (amd64 or ia64 or any other?)

If you are using amd64, lib32gcc1 exists and contains libgcc_s.so.1. I was able to install it when I tried.

If you are using ia64, you should use ia32-libs-core.

This link can tell the package necessary for your architecture.

Sometimes Debian mirrors lose some packages. You can try to install from main US repositories to see if that's the case.

share|improve this answer
    
oh, sorry, it's amd64 –  Magnetic_dud Jan 26 '12 at 10:23
    
Then you should install lib32gcc1. If you can not install it, there is something wrong with your package manager or repository you are using. Trying using http://ftp.us.debian.org servers to your /etc/apt/sources.list (possibly with low priority) and try again. –  utkuerd Jan 27 '12 at 9:50
add comment

Since Debian 7 (Wheezy) you can fix this with:

sudo dpkg --add-architecture i386
sudo apt-get update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.