Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to install the 32bit gcc because i get this error: must be installed for pthread_cancel to work Aborted

I try this:

apt-get install lib32gcc1

Does not find the package

I also try this:

apt-get install ia32-libs ia32-libs-gtk

Does not find either

What I can do?

share|improve this question
up vote 2 down vote accepted

You have not specified the architecture (amd64 or ia64 or any other?)

If you are using amd64, lib32gcc1 exists and contains I was able to install it when I tried.

If you are using ia64, you should use ia32-libs-core.

This link can tell the package necessary for your architecture.

Sometimes Debian mirrors lose some packages. You can try to install from main US repositories to see if that's the case.

share|improve this answer
oh, sorry, it's amd64 – Magnetic_dud Jan 26 '12 at 10:23
Then you should install lib32gcc1. If you can not install it, there is something wrong with your package manager or repository you are using. Trying using servers to your /etc/apt/sources.list (possibly with low priority) and try again. – infiniteRefactor Jan 27 '12 at 9:50

Since Debian 7 (Wheezy) you can fix this with:

sudo dpkg --add-architecture i386
sudo apt-get update
share|improve this answer

My issue was with Debian 7.6 (Wheezy), I looked directly in the package and there is also:

dep: libc6-i386 (>= 2.11) [amd64] Embedded GNU C Library: 32-bit shared libraries for AMD64

So I tried to install it first and it worked for me:

apt-get update
apt-get install libc6-i386
apt-get install lib32gcc1
share|improve this answer

I ran into this same issue and had some problems getting the 32-bit libs installed on Wheezy 7.6. I finally managed to resolve it by targetting 32-bit libgcc1 explicitly:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libgcc1:i386

This will add to /usr/lib32/

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.