Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Setup:

  • wired D-link (EBR-2310) router connected to my cable modem.
  • Wireless NetGear N300 (WNR2000v3) router connected to a LAN port on the wired router.

What I'm trying to do:

I'm trying to setup the wireless router to be a separate network, that only accesses the internet through the wired router.

What I've done so far.

I setup the wireless router's WAN port to get an address from ISP (which should be coming from my wired router running DHCP), and the LAN as a subnet (192.168.1). Wired router's LAN is 192.168.0.

The problem:

I'm not able to connect to the internet from the wireless router. At one point my wired router showed that it was handing out an IP to the wireless router, but that is not happening anymore.

The question:

Is what I'm trying to do possible? Am I not thinking about this properly? Do I need to buy a better wired router, with 2 WAN ports? How can I configure these routers to work together?

share|improve this question
add comment

4 Answers

,--------.
|     wan+------- (ISP)
| Wired  |
|   lan  |
`---++++-'  ,------.
       `----+wan   |
            | Wifi |
            |  lan |
            `--++++'
               ||||
  1. Connect like shown above.
  2. Configure the Wifi router to receive the WAN address via dhcp.
  3. Profit
share|improve this answer
    
Yes. I've done that, and actually said exactly that in the question. –  Tester101 Nov 20 '12 at 13:20
    
Well that's all you need to do, since your subnet settings are legit. Now you have a nice ascii diagram too! –  Ярослав Рахматуллин Nov 20 '12 at 13:24
    
step 3... "Profit" hahahaha - gold –  CheeseConQueso Jun 8 '13 at 16:09
    
You're missing the something magical step. –  Michael Kjörling Jul 18 '13 at 13:43
    
@Tester101 The question didn't say that the connection was to the Wifi router's WAN port. –  David Schwartz May 13 at 23:06
add comment

Although I'm not 100% sure on the options inside each router specifically, on the surface yes, this seems very feasible.

Make sure the WAN port on the 2nd router is connected to the LAN port on the 1st router.

Most routers allow some basic firewall rules to be applied. In the 2nd router simply add a firewall rule to reject all traffic to the subnet on the 1st router... (excluding the ip of the IP of the 1st router itself). Once that's done... you'll be able to connect to the internet but not the private network.

There are much more elegant ways of doing this, but with home-grade equipment and factory-stock firmware... your options are limited.

share|improve this answer
    
Thanks for the answer, but it doesn't really help. I can't get the wireless router to connect to the wired router properly, so messing with firewall settings is the least of my problems at this point. –  Tester101 Jan 25 '12 at 20:18
add comment

For the sake of sanity, and the accepted answer, I will take a stab at describing your setup, the problem, and what troubleshooting steps to take if another user is in this situation.

The setup

enter image description here The problem

  • Clients connected to wireless router cannot reach the internet.

Troubleshooting steps

enter image description here

share|improve this answer
add comment
up vote -3 down vote accepted

Finally got it working.

Physical Connections:

I connected one of the LAN ports on the wired router, to the WAN port of the wireless router.

Configuration

I set up the wireless router to obtain an address from the ISP, so it would be assigned an address from the wired routers address pool. Next I set the wireless routers internal IP address to 192.168.1.1. Next I turned on DHCP on the wireless router, so it would hand out addresses to devices connecting to the 192.168.1.x network. Finally I waited, and waited.

Poor communication is bad for networking

Turns out the problem I was having was that the routers were not sharing information fast enough, and there was no way (that I could find) to force them to speak to each other. The wired router knew where the 192.168.0.x and the external (Internet) networks were, and the wireless router knew where the 192.168.1.x network was. But neither of them wanted to tell the other what they knew. Once they became friends and started talking, the problem resolved itself and everything worked fine.

share|improve this answer
    
For anyone reading this trying to solve a problem, I apologize. There is absolutely no discernible helpful information from either the question, or the answer here. There is not even a fix, the setup is exactly the same in the question and the answer. The only difference is 'They became friends and started talking'. For future reference, there is absolutely nothing wrong with the setup described in the Question, and it should work as intended out of the box as long as the two routers have different subnets (Which the question states is true). –  Mondrianaire May 13 at 20:25
    
This question and answer resulted in a migraine. –  nullmem May 13 at 21:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.