Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A very weird behavior on a MBP. It seems that some websites are now advertising Ipv6 addresses (e.g., www.doodle.com, addons.mozilla.org, etc.).

For some reason, even though I only have an Ipv4 address on the network, Firefox and Safari are trying to connect to the Ipv6 addresses, which of course fails. Even trying telnet to port 80 of those hostnames results in a an attempt to connect via Ipv6. It seems like this problem started around mid-December.

Here's an example:

$ telnet www.doodle.com 80
Trying 2a02:d58:2001::72...
Connected to doodle.com.
Escape character is '^]'.

Connection closed by foreign host. $

share|improve this question

migrated from serverfault.com Jan 25 '12 at 18:59

This question came from our site for professional system and network administrators.

1  
"Connected to" implies that you're making more than an attempt - you're successfully connecting. What happens when you type GET / HTTP/1.0 and hit the return key a couple of times after you connect? –  Gerald Combs Jan 25 '12 at 20:50
    
This issue has been resolved. Even though there ipv6 was not enabled on the network, the problem was related to the fact that Hamachi secure.logmein.com/products/hamachi was earlier installed. Hamachi's default setting was to prefer ipv6. Once this setting was changed to prefer ipv4 the problem went away. Thank you. –  fraser Jan 26 '12 at 17:30

3 Answers 3

Your machine has an IPv6 address. The default behaviour in almost all modern OSes is to prefer IPv6 over IPv4 if it's available and configured. Disabling IPv6 (if you don't use it) is the easiest way to "fix" this.

share|improve this answer
Trying 2a02:d58:2001::72...
Connected to doodle.com.

I think you have just proven that you do have an IPv6 address :-) It might be because your router has 6to4 turned on and that you are using an older Mac OS X release (everything before 10.6.5). 6to4 is not very reliable (understatement...) and if you do have it enabled on your router you should turn it off. If you use Mac OS X 10.6.5 or newer then it doesn't do as much damage because it gets a lower priority than IPv4, but you should probably still turn it off to prevent other computers from trying to use it...

If you provide us the output of

ifconfig

then we can tell you more. If that output contains IPv6 addresses that start with 2002: then your router has 6to4 enabled. Don't worry about addresses that start with fe80:. Those are link-local addresses and they are supposed to be there. They will only be used on your LAN and things like AirPlay need them.

share|improve this answer

http://test-ipv6.com should be able to provide a bit more information. It'll show you your public IPv6 address; and warn if you're using Teredo (not likely on your mac!) or 6to4 (possible, depending on your router).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.