Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Windows 7 on my Mac pro, I have tried everything it seems. I have a perfectly good Windows 7 DVD which boots on other devices, yet it doesn't on mine. First off it started with spitting out the DVD (which I can understand ;) ), so I thought its my superdrive. I went and bought a new drive today, except this is a SATA drive and tried to boot from there. It load the DVD fast and easy within OSX, but when I reboot and try to boot from the disk it hops to a flashing Apple logo and a deny logo (circle with a diagonal line thru it).

What am I doing wrong? The DVD is legal, its not an illegal copy (however, I tried that as well.. and didn't work either). I googled it a bit but cannot find any similar problem.

With flashing logo's, I mean it flashes every second between these two logos: enter image description here

Edit 1
I have now also tried it using Windows 8, downloaded from Microsoft.

Edit 2
I have now also tried it using an Windows XP Disk. Same problem, flashing icons.

Edit 3
I have now also tried:

  • Removing all drives and installing OSX 10.6 on one of the 1TB drives. Using bootcamp and installing. Same problem
  • Reformatted my 750GB Drive and added MBR support. Formatted as Fat drive. Same problem.
  • Removing all drives and trying to boot from disk. Nothing happens, just a white screen.
  • Reset the PRAM so many times that I guess the computer almost tells me to give it a brake.
  • Tried booting with only C hold down. Same problem.

Nothing seems to help.

Also, I just found this page: http://support.Apple.com/KB/HT2674 According to that page, the problem is:

Circle with Slash - could not load boot.efi, or some other issue

and

Metallic Apple - found boot.efi.

More: http://support.Apple.com/KB/TS1892?viewlocale=en_US

Edit 4
I tried all evening to restore the firmware, but it just refuses. The sleep light flashes a few times, the tone comes, then the normal sound boot sound comes and OSX boot like it should. I am getting crazy here.

Edit 5
Tested as well with both 10.5 and 10.6 retail disks, they load perfectly. (Maybe due to that they have GUID formatted?)

share|improve this question
1  
Run the BootCamp Assistant, follow the instructions and insert the DVD when it says to. At what point does it fail? – Brian Jan 25 '12 at 22:42
    
If you don't want to use BootCamp see: derekhat.com/install-vista-on-a-macbook-without-bootcamp – Brian Jan 25 '12 at 22:46
    
Yes, that is exactly what I have done. I also tried booting holding ALT and selecting the disk, booting holding C (Come to a screen which informs me no bootable devices are found). I have now also tried it with Windows 8, downloaded directly from Microsoft. – Paul Peelen Jan 25 '12 at 23:10
    
@Brian I found that site yesterday and tried that as well. Same problem. – Paul Peelen Jan 25 '12 at 23:11
    
What model is this macbook pro exactly? – skub Jan 27 '12 at 0:09
up vote 1 down vote accepted
+50

The Apple article EFI and SMC firmware updates for Intel-based Macs specifies that MacBook Pro 3.1 can only run EFI 1.5.1. (From the article you can also download this EFI version.)

As Windows 7 needs EFI version 2, this means that you cannot boot Windows 7 x64 from the DVD. Some more facts about the EFI problem can be found in Native UEFI Windows 7 Boot on Mac Mini.

You will need to convert the Windows 7 DVD that you have to one that can work on the Mac.

Some resources that may help here are :

Installing Windows 7 x64 on a Mac Pro (Late 2006)
“Select CD-ROM Boot Type :” prompt during Vista, Server 2008 (& R2) & Windows 7 x64 Boot on Macbook

share|improve this answer
    
Thanks, it also showed that the EFI is 1.3 for my computer... the Mac Pro (Not MacBook Pro). However, one question: I have a MacBook Pro as well running 1.8 EFI and is boots the Win 7 disk without a problem. Why is that? I'm gonna try to install it using your first link tip. I'll let you know how it goes. – Paul Peelen Jan 28 '12 at 20:27
    
Different models can support different versions, as in the link. But I don't think that for booting Windows 7 there will be a difference between 1.3 and 1.5. – harrymc Jan 28 '12 at 20:53
    
Ok, I am now downloading the WAIK... I really hope it works. If it does, you're my hero! ;) – Paul Peelen Jan 28 '12 at 21:15
    
Well, you are my hero. I think some EFI thing was screwed up cause I can now boot from the Windows disk after doing the things from your first list. Thanks! – Paul Peelen Jan 29 '12 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .