Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use 'synergy' to make different Linux and Windows PCs appear as one working space for my mouse, keyboard and clipboard.

The problem is that 'synergy' is not very stable, and apparently it sometimes makes Windows (XP, if that matters) "think" that Shift button is always pressed. The most annoying thing is 'Shift+ MouseClick' combination could be mapped to a special functionality by some applications (e.g. Firefox), and mouse becomes barely usable with them.

Rebooting the PC helps to unlock the Shift but obviously this is not the solution I'd like to use.

share|improve this question
    
Do you use the original Synergy or Synergy+ ? –  Snark Sep 9 '09 at 10:16
    
The original one. –  Linulin Sep 9 '09 at 10:26
add comment

3 Answers

up vote 2 down vote accepted

Workaround that helps to avoid the reboot:

  • Right-click on the language bar indicator (in the right corner of your task bar).
  • choose 'Settings',
  • Press 'Key Settings' button in the 'Preferences' area,
  • Choose 'Press the SHIFT key' in 'To turn off Caps Lock' area,
  • Press 'OK' until all 'Settings' dialogs are closed.
  • Press 'Shift' -- Bingo! -- the problem is solved!
  • now repeat the above to switch back to Caps Lock button.

Note that I use two input languages, and switch between them using Ctrl+Shift. If you're only using English, the language bar might not be directly accessible.

P.S. Just thought that may be pressing 'Shift' from the beginning could have solved the issue without changing any settings... I'll check this when I encounter the lock again.

share|improve this answer
add comment

This is apparently a known issue with Synergy, and even with Synergy+ (a fork with a lot of bugfixes). It's being discussed quite intensively here on the issue tracker for Synergy+.

The problem would be that you switch screens (and thus computers) with a special modifier key (Shift, Alt, ...) pressed down. When you release it, the other computer gets the "key up" message, not the one that got the "key down" message initially. So the state of the modifier key is not released.

Until they have a fix for this, you'd better not switch screens while pressing one of these keys.

share|improve this answer
    
Snark, I like your elegant explanation of the root of the problem, but it seems to be more complicated. That is, I can't reproduce the issue by simply pressing one of Shift, Alt, Ctrl, Ctrl+Shift, Caps Lock keys, and moving mouse from one screen to another... BTW, thanks for the links! I'll take a closer look to Synergy+ when time permits. –  Linulin Sep 9 '09 at 10:52
add comment

Jeesh, 4 years later in 2013 and this is still a problem?

Anyways, I just solved it by toggling sticky keys on and off on the windows computer that was acting all janky. Just tap 'Shift' five times, toggle to your heart's delight, and hopefully things should work out from there. My next step: Swapping my caps lock for a 'ctrl' modifier instead like I do on my linux machines. Who actually uses the caps lock anyways, is it just me or is that key for crazy old people who think that people will see what they have to say better? Or maybe we suck at thinking about accessibility, and it helps their old eyes see the keys? Anyways, I digress.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.