Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to turn off "Public Folder Sharing" in advanced options, for Public networks. The problem is that it also affects "Home or Work (current profile)". When I change the setting in either "Home or Work" or "Public", both are changed. The rest of the settings are working fine. How can I disable Public Folder Sharing for Public networks only?

share|improve this question
    
Let me know if my answer is what you are after. – Amicable Apr 30 '12 at 9:15

You can change the Public/Work/Home profiles. (I realise you know this putting down for other people)

Open the Network and Sharing Center "Choose Homegroup and Sharing Options" "Change Advanced Sharing Settings..."

You will then be able to see the profiles for "Home or Work", "Public" and also "Domain" if you aren't using Windows Home edition.

While the "Public folder sharing" option changes for both Home & Public (Who knows why?) you can achieve what you want by checking "Turn off File and Printer" sharing in the Public profile.

This means on the public setting no one will be able to view your shared folders, whether they are your Public folder or otherwise.

share|improve this answer

You must log in to answer this question.