Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm creating a stand-alone set of netboot images based on a LinuxFromScratch installation (7.0, kernel 3.1.0). I want to deploy that image to many diskless clients, but NFS is in my situation not an option. The root filesystem has been trimmed down to an ext2 image of 350mb uncompressed (with 7% free space included).

I tried to boot the kernel over the network using PXELINUX, by passing the root filesystem (root.img) as initrd using this PXELINUX config:

label pxeboot
  kernel /bzImage
  append rw root=/dev/ram0 ramdisk_size=512000 initrd=/root.img

However, linux panics with "no filesystem could mount root, tried: ext3 ext2 iso9660 udf". This is the closest I could get, if I change the root= parameter, I get a panic telling me that it couldn't find a root device. (no filesystem sounds closer to my goal than no device).

My question is now: where do I start looking to solve this - I think I misconfigured the kernel image, but I do not know which settings I could alter to make this work.

share|improve this question
    
have you go inird and ramdisk support enabled in kernel? –  user377178 Jan 28 '12 at 12:52
    
yes, I compiled it into the kernel... –  friedkiwi Jan 28 '12 at 14:08
    
350mb seem to be a lot for tftp: are you able to verify that initrd file is transferred properly. E.g. by checking the tftpd log? –  user377178 Jan 28 '12 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.