Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem: Outlook won't open the calendars on another user's mailbox and and a room mailbox, even when users have permission.

Note: This problem is affecting more than one account on more than one machine.

So I have a room mailbox and a personal mailbox on Exchange, both with shared calendars. There is a security group called "Scheduling Users" that have editor rights on both of these calenders.

The room mailbox was created using PowerShell, per the instructions posted online (http://help.outlook.com/140/ee441202.aspx).

Sharing worked on both of these folders initially. Users can still access these folders using OWA.

So on to the problem. When users try to open these calendars in Outlook they receive one of the following messages.

  • The set of folders cannot be opened. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance.

  • Cannot open this item. Cannot open the free/busy information. The attempt to log on to Microsoft Exchange has failed.

What I have tried so far:

  • Resetting the permissions on both of the mailboxes. I deleted the security group permissions on both mailboxes, applied the change, then waited a bit and gave the permissions back.

  • Deleted the OST file of the shared calendar from the Outlook data directory

That is all I have been able to find online. Any thoughts? I have been going back and forth with the Office365 support folks for a while and they seem stumped too.

share|improve this question

2 Answers 2

Further mailbox permissions may be required as per TechNet forum post

I had the same problem and this worked for me.

share|improve this answer

I had the same experience. There were a couple of clues as to the cause however:

  1. Some people with rights on the resource still could access it.
  2. Around the same time, I noticed an increase in the "Sync Issues" emails.

Sadly, the fix isn't fun. The problem lies within Outlook, and not Exchange. You need to wipe away your mail profile and re-create it.

Instructions [Assuming you only use one mail account - see below if you have more]:

  1. Exit Outlook
  2. Control Panel > Users > Mail > Email Accounts [See below if you have more than one account]
  3. Create a new dummy account. Fill it out with fake data (temp@temp.com or something). Don't test.
  4. Delete your Real Outlook account. (Don't close this window, you'll want it again soon)
  5. Start > "explorer %APPDATA%\Microsoft\Outlook" (no quotes)
  6. Delete all the files here.
  7. In the Address bar of your explorer, go to %LOCALAPPDATA%\Microsoft\Outlook and delete these files also.
  8. Close your Explorer window and return to the Account Settings (E-mail Accounts) window.
  9. Create a New account, E-mail Account - configure as per normal for your Exchange server.
  10. Delete your dummy account.
  11. Start Outlook. It will re-synchronise all your mail, and you'll now be able to access the shared resource again. You may see the remnants of your dummy account in the folder list. Just right-click on it and remove it from Outlook.

If you have more than one account:

If you have more than one account configured, you'll need to be a little cautious with these instructions. You can skip steps 3 and 10 completely. With steps 6 and 7, you'll want to be careful to leave the files related to your other mail account(s). The main files you need to delete are named after your affected email address. In particular the (probably quite large) user@domain.com.ost file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.